Network Simulator
cancel
Showing results for 
Search instead for 
Did you mean: 

MPLS-TE on H3C CLOUD LAB

 
Highlighted
Frequent Visitor

MPLS-TE on H3C CLOUD LAB

Hello,

First, i apologize for my english.

On the simulator i try to make a mpls-te tunnel like the exemple on the "HP MSR2000/3000/4000 router series MPLS configuration guide V7" on page 72 (Establishing an inter-AS MPLS TE tunnel with RSVP-TE).

My netwok is ok about OSPF and BGP. The ip routing table confirm that.

But when i configure the tunnel, the network i would to reach don't pass by the tunnel. On the Ip routing table is again learn by ospf

Did someone succed to doing a inter-AS MPLS-TE ?

 

Tanks

 

2 REPLIES 2
Highlighted
HPE Pro

Re: MPLS-TE on H3C CLOUD LAB

Hello ,

As per my undestanding ton your network the traffic should pass inside the tunnel -- Correct me if i am wrong . Can you please share us the configuration which you have made  .

Thanks,

JMPK


I work for HPEAccept or Kudo
Highlighted
Frequent Visitor

Re: MPLS-TE on H3C CLOUD LAB

first i apologize for  the delay of my answer.

In the example given in the documentation wich a refer on my last message. My network has to pass trough the tunnel mpls-te to join another network.

Documentation here : https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c02659399 

<ROUTER A>di cu
#
 version 7.1.075, Alpha 7571
#
 sysname ROUTER A
#
ospf 1
 area 0.0.0.0
  network 1.1.1.9 0.0.0.0
  network 10.1.1.0 0.0.0.255
  mpls te enable
#
 mpls lsr-id 1.1.1.9
#
 system-working-mode standard
 xbar load-single
 password-recovery enable
 lpu-type f-series
#
vlan 1
#
mpls ldp
 lsr-id 1.1.1.9
#
mpls te
#
explicit-path atod
 nexthop index 1 10.1.1.2 include loose
 nexthop index 101 20.1.1.2 include loose
 nexthop index 201 30.1.1.2 include loose
#
rsvp
#
interface Serial1/0
#
interface Serial2/0
#
interface Serial3/0
#
interface Serial4/0
#
interface NULL0
#
interface LoopBack0
 ip address 1.1.1.9 255.255.255.255
#
interface GigabitEthernet0/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet0/1
 port link-mode route
 combo enable copper
 ip address 10.1.1.1 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls te enable
 mpls te max-link-bandwidth 10000
 mpls te max-reservable-bandwidth 5000
#
interface GigabitEthernet0/2
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/1
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/1
 port link-mode route
 combo enable copper
#
interface Tunnel1 mode mpls-te
 ip address 7.1.1.1 255.255.255.0
 mpls te bandwidth ct0 2000
 mpls te path preference 5 explicit-path atod
 destination 4.4.4.9
#
 scheduler logfile size 16
#
line class aux
 user-role network-operator
#
line class console
 user-role network-admin
#
line class tty
 user-role network-operator
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-operator
#
line con 0
 user-role network-admin
#
line vty 0 63
 user-role network-operator
#
 ip route-static 30.1.1.0 24 Tunnel1 preference 1
#
domain name system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
return

---------------------------------------------------------------------------------------------------

<ROUTER B>di cu
#
 version 7.1.075, Alpha 7571
#
 sysname ROUTER B
#
ospf 1
 import-route direct
 import-route bgp
 area 0.0.0.0
  network 2.2.2.9 0.0.0.0
  network 10.1.1.0 0.0.0.255
  mpls te enable
#
 mpls lsr-id 2.2.2.9
#
 system-working-mode standard
 xbar load-single
 password-recovery enable
 lpu-type f-series
#
vlan 1
#
mpls ldp
 lsr-id 2.2.2.9
#
mpls te
#
rsvp
#
interface Serial1/0
#
interface Serial2/0
#
interface Serial3/0
#
interface Serial4/0
#
interface NULL0
#
interface LoopBack0
 ip address 2.2.2.9 255.255.255.255
#
interface GigabitEthernet0/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet0/1
 port link-mode route
 combo enable copper
 ip address 10.1.1.2 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls te enable
 mpls te max-link-bandwidth 10000
 mpls te max-reservable-bandwidth 5000
 rsvp enable
#
interface GigabitEthernet0/2
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/0
 port link-mode route
 combo enable copper
 ip address 20.1.1.1 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls te enable
 mpls te max-link-bandwidth 10000
 mpls te max-reservable-bandwidth 5000
 rsvp enable
 rsvp hello enable
#
interface GigabitEthernet5/1
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/1
 port link-mode route
 combo enable copper
#
bgp 100
 peer 20.1.1.2 as-number 200
 #
 address-family ipv4 unicast
  import-route direct
  import-route ospf 1
  peer 20.1.1.2 enable
#
 scheduler logfile size 16
#
line class aux
 user-role network-operator
#
line class console
 user-role network-admin
#
line class tty
 user-role network-operator
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-operator
#
line con 0
 user-role network-admin
#
line vty 0 63
 user-role network-operator
#
domain name system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
return

 

------------------------------------------------------------------------

<ROUTER C>di cu
#
 version 7.1.075, Alpha 7571
#
 sysname ROUTER C
#
ospf 1
 import-route direct
 import-route bgp
 area 0.0.0.0
  network 3.3.3.9 0.0.0.0
  network 30.1.1.0 0.0.0.255
  mpls te enable
#
 mpls lsr-id 3.3.3.9
#
 system-working-mode standard
 xbar load-single
 password-recovery enable
 lpu-type f-series
#
vlan 1
#
mpls ldp
 lsr-id 3.3.3.9
#
mpls te
#
rsvp
#
interface Serial1/0
#
interface Serial2/0
#
interface Serial3/0
#
interface Serial4/0
#
interface NULL0
#
interface LoopBack0
 ip address 3.3.3.9 255.255.255.255
#
interface GigabitEthernet0/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet0/1
 port link-mode route
 combo enable copper
 ip address 30.1.1.1 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls te enable
 mpls te max-link-bandwidth 10000
 mpls te max-reservable-bandwidth 5000
#
interface GigabitEthernet0/2
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/0
 port link-mode route
 combo enable copper
 ip address 20.1.1.2 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls te enable
 mpls te max-link-bandwidth 10000
 mpls te max-reservable-bandwidth 5000
 rsvp enable
#
interface GigabitEthernet5/1
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/1
 port link-mode route
 combo enable copper
#
bgp 200
 peer 20.1.1.1 as-number 100
 #
 address-family ipv4 unicast
  import-route direct
  import-route ospf 1
  peer 20.1.1.1 enable
#
 scheduler logfile size 16
#
line class aux
 user-role network-operator
#
line class console
 user-role network-admin
#
line class tty
 user-role network-operator
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-operator
#
line con 0
 user-role network-admin
#
line vty 0 63
 user-role network-operator
#
domain name system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
return

 

------------------------------------------------------------------------

<ROUTER D>di cu
#
 version 7.1.075, Alpha 7571
#
 sysname ROUTER D
#
ospf 1
 area 0.0.0.0
  network 4.4.4.9 0.0.0.0
  network 30.1.1.0 0.0.0.255
  mpls te enable
#
 mpls lsr-id 4.4.4.9
#
 system-working-mode standard
 xbar load-single
 password-recovery enable
 lpu-type f-series
#
vlan 1
#
mpls ldp
 lsr-id 4.4.4.9
#
mpls te
#
rsvp
#
interface Serial1/0
#
interface Serial2/0
#
interface Serial3/0
#
interface Serial4/0
#
interface NULL0
#
interface LoopBack0
 ip address 4.4.4.9 255.255.255.255
#
interface GigabitEthernet0/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet0/1
 port link-mode route
 combo enable copper
 ip address 30.1.1.2 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls te enable
 mpls te max-link-bandwidth 10000
 mpls te max-reservable-bandwidth 5000
 rsvp enable
 rsvp hello enable
#
interface GigabitEthernet0/2
 port link-mode route
 combo enable copper
#
interface GigabitEthernet5/0
 port link-mode route
 combo enable copper
 rsvp hello enable
#
interface GigabitEthernet5/1
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/0
 port link-mode route
 combo enable copper
#
interface GigabitEthernet6/1
 port link-mode route
 combo enable copper
#
 scheduler logfile size 16
#
line class aux
 user-role network-operator
#
line class console
 user-role network-admin
#
line class tty
 user-role network-operator
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-operator
#
line con 0
 user-role network-admin
#
line vty 0 63
 user-role network-operator
#
domain name system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
return