Software Defined Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

unable to install flow due to version mismatch exception

 
Highlighted
New Member

unable to install flow due to version mismatch exception

Hi,

I am unable to add a flow in RSdoc.

The request body which i am sending is:

 

{"flow": {
"priority": 30000,
"table_id": 200,
"idle_timeout": 60,
"match": [
{"ipv4_src": "192.168.1.11"},
68
{"ipv4_dst": "192.168.1.9"},
{"ip_proto": "tcp"},
{"eth_type": "ipv4"},
{"tcp_dst": "80"}
],
"instructions": [{"apply_actions": [{"output": 6}]}]
}}

 

 

The url which is being sent is :

 

https://localhost:8443/sdn/v2.0/of/datapaths/00%3A02%3A2c%3A59%3Ae5%3A14%3A6b%3A80/flows

 

The response body which i am getting is :

 

{
"error": "com.hp.of.lib.VersionMismatchException",
"message": "Not supported before version 1.1"
}

 

I am using a physical switch .The MAC address of the switch is :  00:02:2c:59:e5:14:6b:80

 

I am using 2 hosts 192.168.1.9 and 192.168.1.11

 

Please help.

 

Thanks in Advance!

 

1 REPLY 1
Highlighted
Valued Contributor

Re: unable to install flow due to version mismatch exception

Hello,
From the error message you received it seems to me that your switch is running openflow version 1.0 And you are adding the flow to table 200 (not supported on v 1.0 that uses a single table.
which switch are you using?
Does it support version 1.3?
Can you provide these details along with the switch configuration guide.

Regards,
Antonio