Software Defined Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong OpenFlow negotiation between HP3800 and HP VAN Controller

 
Highlighted
Frequent Advisor

Wrong OpenFlow negotiation between HP3800 and HP VAN Controller

Hello, 

 

I don't understant why my switchs HP3800 and HP3500 negotiated with my HP VAN Controller by using OF 1.0 and not OF1. 3. 

 

The screen capture  "nego.png" show that all my HP switch have negotiated in version 1.0.

On the same capture, you can see that the swith being IP 130.223.23.105 negotiated correctly in 1.3.0 (this is not an HP switch).

 

The screen capture "instance.png" show the Openflow instance information for one of my HP switch HP3800 with IP adresse 130.223.23.101. As you can see, the configures OF version is 1.3, but the negotiated is 1.0.

 

Why ?

 

Here is the HP 3800 running  config:

 

hostname "hpmax1"
 openflow
    controller-id 1 ip 130.223.23.100 controller-interface vlan 23
    instance aggregate
       controller-id 1
       software-flow-table 4
       version 1.3
       enable
       exit
    enable
    exit 
 oobm
    ip address 130.223.38.8 255.255.252.0
    ip default-gateway 130.223.36.1
    exit
 vlan 1
    name "DEFAULT_VLAN"
    no untagged 1-2,5-24
    untagged 3-4,25-26
    ip address dhcp-bootp
    exit
 vlan 20
    name "sdn-client"
    untagged 5-22
    no ip address
    exit
 vlan 23
    name "sdn-cnt"
    untagged 1-2, 23-24
    ip address 130.223.23.101 255.255.255.0
    exit
    

 

As you can see the OF version is 1.3 and not 1.0.

 

An idea ?

 

4 REPLIES 4
Highlighted
Frequent Advisor

Re: Wrong OpenFlow negotiation between HP3800 and HP VAN Controller

here is nego.png

Highlighted
Trusted Contributor

Re: Wrong OpenFlow negotiation between HP3800 and HP VAN Controller

Hello sbotkine,

 

Thanks for your query.

Please provide below details-

1. Controller version?

2. Switch Firmware version?

3. Controller’s hybrid mode is enabled or disabled?

4.Running config of HP 3500?

 

Thanks,

HP SDN Team

Highlighted
Frequent Advisor

Re: Wrong OpenFlow negotiation between HP3800 and HP VAN Controller

Helllo, 

 

 

1. Controller version?

 

2.3.5

 

2. Switch Firmware version?

 

HP 3800 -> KA.15.15.0006

HP 3500 -> K.15.15.0006

 

3. Controller’s hybrid mode is enabled or disabled?

 

hybrid.mode = true

 

4.Running config of HP 3500?

 

hpmax3# sh run

Running configuration:

; J8692A Configuration Editor; Created on release #K.15.15.0006
; Ver #05:18.7f.ff.3f.ef:4d
hostname "hpmax3"
module 1 type j86xxa
snmp-server community "public" unrestricted
openflow
controller-id 1 ip 130.223.23.100 controller-interface vlan 23
instance aggregate
controller-id 1
software-flow-table 4
version 1.3
enable
exit
enable
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 1-2,5-24
untagged 3-4
ip address dhcp-bootp
exit
vlan 20
name "sdn-client"
untagged 5-23
no ip address
exit
vlan 23
name "sdn-cnt"
untagged 1-2,24
ip address 130.223.23.103 255.255.255.0
exit
vlan 136
name "wlmm"
no ip address
exit
vlan 224
name "wls1"
no ip address
exit

hpmax3#

 

 

Regards, 

 

Serge

Highlighted
Trusted Contributor

Re: Wrong OpenFlow negotiation between HP3800 and HP VAN Controller

Hello Serge,

 

Please see below logs of our testing/analysis and attached screenshot-

VAN 2.3.5 controller/3500 switch with K.15.15.0006 image/ controller’s hybrid mode enabled.

 

HP-3500yl-24G(openflow)# sh openflow instance a

 

Configured OF Version    : 1.3

Negotiated OF Version    : 1.3

Instance Name            : aggregate

Admin. Status            : Enabled

Member List              : VLAN 1, 3

Listen Port              : None

Oper. Status             : Up

Oper. Status Reason      : NA

Datapath ID              : 1000001b3ff6ca00

Mode                     : Active

Flow Location            : Hardware and Software

No. of Hw Flows          : 4

No. of Sw Flows          : 7

Hw. Rate Limit           : 0 kbps

Sw. Rate Limit           : 100 pps

Conn. Interrupt Mode     : Fail-Secure

Maximum Backoff Interval : 60 seconds

Probe Interval           : 10 seconds

Hw. Table Miss Count     : NA

No. of Sw Flow Tables    : 4

Egress Only Ports        : None

Table Model              : Policy Engine and Software

 

Controller Id Connection Status Connection State Secure Role

------------- ----------------- ---------------- ------ ------

1             Connected         Active           No     Equal

 

HP-3500yl-24G(openflow)# show run

 

Running configuration:

 

; J8692A Configuration Editor; Created on release #K.15.15.0006

; Ver #05:18.7f.ff.3f.ef:4d

hostname "HP-3500yl-24G"

module 1 type j86xxa

module 3 type j9312a

snmp-server community "public" unrestricted

openflow

   controller-id 1 ip 20.1.1.2 controller-interface vlan 2

   instance aggregate

      controller-id 1

      software-flow-table 4

      version 1.3

      enable

      exit

   enable

   exit

vlan 1

   name "DEFAULT_VLAN"

   no untagged 1-2

   untagged 3-24,A1-A4

   ip address dhcp-bootp

   exit

vlan 2

   name "VLAN2"

   untagged 2

   ip address 20.1.1.1 255.255.255.0

   exit

vlan 3

   name "VLAN3"

   untagged 1

   no ip address

   exit

 

||/ Name                              Version                           Description

+++-=================================-=================================-==================================================================================

ii  hp-sdn-ctl                        2.3.5.6505                        HP VAN SDN Controller

 

Please provide the wireshark packet capture of the packets that are exchanged between the switch and controller during version negotiation.

 

Thanks,

HP SDN Team