3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't see my host's wwn in 3PAR

Can't see my host's wwn in 3PAR

I can't see my host's wwn in 3par , although I can see it in switch and zoning is done perfectly.

 

Here is my environment...

 

I have two c7000 enclousres and I am planning to present 3par volumes to the servers in those enclosures.

When powered on the servers I can see its wwn in switch and did zoning. (Enclosure 1 and 2 are working fine untill this step)

But when I create host in 3par , I can't see the wwn of Enclosure 1 servers (Enclosure 2 is working fine).

 

I suspect that I misconfigured VC in Enclosure 1. But I could see the wwn of Enclosure 1 servers in switch , hence assuring myself VC is not a problem.

 

Someone help me where to start my debugging ?

14 REPLIES
Torsten.
Acclaimed Contributor

Re: Can't see my host's wwn in 3PAR

Check the settings for the 3par ports. Must be target, not initiator.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   

Re: Can't see my host's wwn in 3PAR

I checked those settings. It is not a problem as one server is working fine.

 

Additional information : I created another one server profile. So totally now I have 3 server profile. 

1 st server profile - Bay 8  : WWN can be discoverd in switch and also in 3PAR . Working fine and can assign volumes.

2nd server profile - Bay 9 : WWN can be discovered in switch , but cant see WWN in 3PAR

3rd server profile - Bay 7 : WWN cannot be seen in switch and not hence can't see in 3PAR

moumen
Occasional Contributor

Re: Can't see my host's wwn in 3PAR

i had the same issue with HPUX V3 and i fixed it

1- check that zoning is done perfectly

2-from the 3PAR IMC, add manually the WWN of your two HBA (click on assign in the host wizard)

3- rescan fromthe host using #ioscan -fnNCdisk

 

and it will work

MACHETASO
Visitor

Re: Can't see my host's wwn in 3PAR

I ran into this same issue with 2 new blades. I added the wwn manually as stated in this post. However, it still not seeing hosts (see attached pic). Where exactly do I run the #ioscan -fnNCdisk command?

Dennis Handly
Acclaimed Contributor

Re: Can't see my host's wwn in 3PAR

>Where exactly do I run the #ioscan -fnNCdisk command?

 

Only on your HP-UX system.  :-)

MACHETASO
Visitor

Re: Can't see my host's wwn in 3PAR

I am not running HP-UX. Is there any other way of accomplishing the same task without HP-UX?

 

MACHETASO
Visitor

Re: Can't see my host's wwn in 3PAR

For anyone else having this issue. In virtual connect manager your server ports are most likely "not logged in" under HP VC FlexFabric Module . From ESXi shell:


# esxcfg-fcoe -d vmnic2
# esxcfg-fcoe -d vmnic3

Reference this thread for the original post:
http://h30499.www3.hp.com/t5/HP-BladeSystem-Virtual-Connect/BL460c-Gen-with-V2-Intel-CPUs-can-t-see-534FLB-s-HBA/m-p/6275753#M3158

Re: Can't see my host's wwn in 3PAR

Hi, 

 

have you got solution , i am facing same issue .

 

 

Bay 1 : WWN nuber discovered in Brocade San switch , Discovered in 3PAR(10800) working fine 

BAY 2 : WWN number discovered in Brocade san switch , but not discovering in 3PAR

BAY3 : WWN nuber discovered in Brocade San switch , Discovered in 3PAR(10800) working fine 

 

vc profile is same for all the blade servers ,

 

I have installed ESXi6.0 boot from SAN in bay1 abd 3 but i am not able in bay 2

 

even i have added host WWN manually in 3par but no luck 

 

Thanks&Regards,

Venkat

Marc_Zandboer
Occasional Visitor

Re: Can't see my host's wwn in 3PAR

We ended up rebooting the 3Par... :O After this all WWNs were shown. No Server-Reboot, no Portdisable on Switches or 3Par helped.

I think we tried everything without success. Last option was reboot of our 3Par.

venkat2311
Frequent Visitor

Re: Can't see my host's wwn in 3PAR

Hello Marc, Did you really have to reboot ? did you reboot nodes one by one?

We have a similar problem where ports are detected on one fabric and not appearing on second fabric.

Was node restart suggested by 3par support?

Many thanks. Please can anyone share similar experience and resolution.

Dennis Handly
Acclaimed Contributor

Re: Can't see my host's wwn in 3PAR

Have you tried using "showportdev findport WWN N:S:P"?

Where the WWN is that of the host's HBA.  And the N:S:P is one of the ports connected to the FC fabric.

You can also use "showportdev fcfabric N:S:P" to list all of the connected devices.

This should ignore any zoning.  So if you see it but can't connect, it's likely a zoning issue.

Angelo2
Occasional Visitor

Re: Can't see my host's wwn in 3PAR

Have dealt with this proiblem a number of times.

When adding in a HPUX host to 3par it seems in short you need to manually create the initators using 3PAR CLI

here are the steps that have worked for me:

  1. Complete all your switch zoning
  2. Manually Create your 3PAR Host entry to initiate connection using following 3PAR CLI command:

    createhost -persona 7 hpux-hostname 1122334455667799(WWN) 1122334455667788(WWPN)

  3. Add the second HBA WWN using the same steps above for the second or subsequent HBAs using the following command in 3PAR CLI:

    createhost -add hpux-hostname 1122334455667799(WWN) 1122334455667788(WWPN)

  4. Rescan HBAs on the HPUX server - (#ioscan –fnNCdisk)    *** You need this step otherwise WWNs wont show up !
  5. Your host should be present now with the HBA ports assigned and connected to the 3PAR ports as normal N:S:P.
  6. Check Host initiators on 3PAR (edit host properties). Sometimes the above commands adds the WWNN (WWnode name) as an initiator and you only need the Port Name there.  – remove any WWNN initiators as required so all you should see are the WWNs you require the same as your other host servers.

Have done it this way several times !

 

Dennis Handly
Acclaimed Contributor

Re: Can't see my host's WWN in 3PAR

If you have Host Explorer running on the hosts, you will be able to see an entry for that host in showhost.

showhost -agent will show more info.

mashal
Occasional Visitor

Re: Can't see my host's WWN in 3PAR

I had the exact same issue as most of you guys and here is how i fixed it:

1) Ensured zoning was correct and presented
2) Re-did the server profile, generated new WWNs and rezoned.
3) Checked 3par management console to edit the host but still only one set of WWNs visible. 
4) In the edit host screen, i attempted to manually add the missing WWN. It failed but gave me an error message saying that WWN is already in use! Did some digging around and determined that:

VMM manages objects so when it sees some sort of presence it goes ahead and creates a host automatically.  Therefore, under the list of hosts you will see "host-"WWN"" in that format. Make sure to shut down your host, and delete this host from 3PAR.  It took quite a few minutes for me to complete. I'm sure its similar in VMWare when you are re-purposing or re-building a blade host within a cluster. 

5) Power your host back on, and once it is back up edit host in 3PAR and you will see all WWNs present. Ta da!