Array Performance and Data Protection
Showing results for 
Search instead for 
Did you mean: 

mounting snapshot lun

Go to solution
Frequent Advisor

mounting snapshot lun

I need to restore something from a snashop lun.

So I went to the volume and set the snapshot online

Then rescanned my hosts in vsphere and tried to add it with the option of assign new signature.

but keep getting an error saying an unknown error has occcured.

any idea?

New Member

Re: mounting snapshot lun

Hi Tony,

Most likely what is happening is the Snapshot is online but it's not writable. In order to mount a snapshot of a VMFS filesystem, as you correctly pointed out, you'll need to Re-signature thus the snapshot needs to be writable as well. What you want to do is:

1) create a clone from the existing Snapshot

2) Host Rescan

3) Add Storage

4) Select the cloned volume

5) Add new Signature

The snapshot will mount as "Snap-xxxxxxxx-Original-Datastore-Label"


Frequent Advisor

Re: mounting snapshot lun

I tried cloning the snapshot lun but when i go to add lun, it showed 2 luns available to add and only gave the format lun option

New Member

Re: mounting snapshot lun

Hi Tony,

Hi Tony,

  Assuming you're running ESXi 4.0 or above and the LUN is a clone of an existing VMFS datastore and not an RDM, you should have 3 options: a) Format b) Assign New Signature c) Keep existing Signature

Here's the process

Additionally, you may want to place a quick call into the Support center. It should be pretty straight forward to get to the bottom of this.



HPE Blogger

Re: mounting snapshot lun

+1 to the above.

I'd also recommend doing the process of cloning the snapshot through the vCenter plugin (available from NimbleOS and above), as it will create the clone, mount it up, resignature the datastore and make it available for you in a 1-click process.

Nick Dyer
Global Storage Field CTO & Evangelist

twitter: @nick_dyer_
Occasional Visitor

Re: mounting snapshot lun

i have the same issue.  i created the volume from a snapshot, and when i try to add storage, the only option listed is format.  the other two are greyed out.

Occasional Advisor

Re: mounting snapshot lun

Make sure you uncheck the Snapshots box when presenting the volume, that way only one copy is being presented to VMware, this is an issue I've seen as they are both on by default.