BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460c/Qlogic 2462HBA/Virtual Connect FC issues

 
Wezley Hunter
Occasional Advisor

BL460c/Qlogic 2462HBA/Virtual Connect FC issues

Hi,
We have recently purchased a HP blade system with a HP Virtual Connect 10GB Ethernet and a Virtual Connect Fiber Channel module. We are having real difficulty trying to get the Qlogic HBA to see our HP EVA5000 on our SAN.

Our SAN consist of a Cisco MDS 9506 running SanOS 3.0(3) with NPIV enabled on the fabric.
Each blade has a Qlogic QMH2462 mezzanine card running the latest firmware and drivers for all components. The VC Ethernet Module is in interconnect bay 1 and the VC FC is in interconnect bay 5 to ensure the port mappings are correct. These have been verified and are showing as linked properly.

Firmware revisions are as follows:
OBA: 1.30
Virtual Connect Manager (1.15a)
VC Eth: 1.15
VC FC: 1.02
Qlogic HBA FW: 1.26
Blade ROM version: I15 05/01/2007

Blade software configuration is as follows:
Windows Server 2003 x64 R2 w SP2
Proliant Support Pack 7.70
HP/Qlogic Driver Version: 9.1.3.16

The Virtual Connect domain is set to use HP VC assigned WWNs and the HBAs are showing up on the Cisco MDS san switch correctly. The ports WWN is being assigned a FCID correctly and is showing up the active zone set configuration. We just cannot see any presented disks to the host.

Within the Fast!Util of the HBA the Scan Fiber devices isn’t showing any devices either. Does anyone know if there are any known issues/bugs with the configuration above?

Thanks
7 REPLIES
Wezley Hunter
Occasional Advisor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

Hi,
Has anyone else gotten the Virtual Connect Fibre Channel module working with a Cisco MDS 9500 running SANOS 3.0(3) and a HP EVA, in fact any other fibre channel storage device?
We cannot get the host to see any targets with zoning being setup correctly.
Need to know if others are experiencing similar problems with the Qlogic HBA or even if the Emulex one works?

Thanks
Rob Leadbeater
Honored Contributor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

Hi,

I could be completely off the mark here as I've not used C-Class blades, but is the BIOS enabled with Fast!Util ?

That has stopped me seeing an EVA from a DL380 with Qlogic cards - especially when trying to set up boot from SAN.

Hope this helps,

Regards,

Rob
Wezley Hunter
Occasional Advisor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

Thanks for the suggestion! Unfortunately I already tried this during my testing but to be on the safe side I thought I would try it again. Have just tested it now and still no change. Nothing is showing up in the device list in SAN Surfer and isnt picking up any presented LUNs etc..
Jan Mietle
Occasional Advisor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

Hi Wezley
I've managed to get this working but with a few differences.

1. Our blades are BL465c so we have a different ROM (A13)
2. We use Emulex cards on the blades in MEZ port 1 As we have the Quad port NIC in port 2 (Has to be doen this way as the second port is the only one that supports 4 channels). However at this moment in time we have only implemented the first 2 NICs on the quad port NIC (I.e. we are using 4 NIC's in total.) This in turn forces the VC FC modules to be in Bay 3 and Bay 4 as a result of the portmapping on the backplane of the blades. HP do recommend that HBA goes in Mez 1 and that forces that VC FC into bay 3 and bay 4. Might be worth trying that.
3. On the software front though we use VMware VI3 (ESX 3.0.1) with PSP 7.70

Apart from that our config looks very similar, both on the blade chassis firmware and the EVA. Our MDSs are running 3.0(2) though with NPIV and the EVA is 3.0.28 controller version though.

Today I presented a 500GB LUN to the hosts and it all works beautifully (I was nervous though as previous disk was timing out all the time, but that was down to a firmware issue with the Emulex cards).

I can't think of anything else to suggest. Let us know how you get on...

Best regards,

Jan
Wezley Hunter
Occasional Advisor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

Hi Jan,
Thanks for the info! Much appreciated...
Itâ s good to know that the HP Virtual Connect FC module works with the Cisco MDS 9506 at least!

I have tried the configuration you have suggested (moving the HBA Mezzanine card into Slot 1 on the blade and the VC-FC module to Bay 3) - it should be in there in the first place anyway as the HBA doesnâ t require 4 channels.

By the looks of things now itâ s the Qlogic HBA that is at fault. I have a case raised with HP at the moment and L2 support are working on it. Just hope they manage to resolve the issue either via a Firmware update or driver update. I have gone as far as updating the Qlogic HBA driver to a newer version that isnt listed on HP's site (yet) to see if it makes a difference but still no luck unfortunately.

Thanks for all your help!
Kindest Regards,
Wez
Wezley Hunter
Occasional Advisor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

I have finnaly managed to get it working. The Qlogic card can be flashed in two ways (DOS or SAN Surfer util). I originally updated the HBA's via the DOS based method and it showed as the correct version but didnt detect any paths on the SAN to our EVA. After many different tests I decided to re-try and flash the HBA via SAN Surfer (Utilities > Update Option ROM) and used the same latest version that I did during the DOS flash.

After a reboot it started magically working. Have done this to three of our Blades now and it seems fine.

Now why on earth did it do that in the first place?

Ah well...

Thanks for all the help anyway!
Wezley Hunter
Occasional Advisor

Re: BL460c/Qlogic 2462HBA/Virtual Connect FC issues

See comments in thread...