BladeSystem Virtual Connect
Showing results for 
Search instead for 
Did you mean: 

Cannot configure NIC Teaming with VC private network configured.

Trusted Contributor

Cannot configure NIC Teaming with VC private network configured.

Gary had a NIC teaming issue:




                I have a customer with Windows hosts that wants to configuring NIC teaming.  The VC network that will support the team has the private network option enabled.  Problem is when they try to configure teaming using the HP utility, one of the NICs in the team has a red X.  If we disable private network, then the red X goes away.




Herman and Chris answered:




Herman replied: 

All NICs in a team need to be in the same broadcast domain (VLAN) and using the private network selection in VC prevents NIC team members from communicating with each other.  HP NIC Teaming uses path validation frames to verify that all team members can successfully send and receive.  This is an additional level of fault detection above simple link failover (think something like beacon probing in ESX).  If using private network in VC is a design requirement for the customer, you could disable path validation in the NCU and just rely on NIC link loss to trigger failover.  Using an Active/Active VC uplink setup and smartlink would help to provide that additional level of upstream fault detection.


And Chris added: 

The only way to address this is to disable TX and/or RX Path Validation within Network Configuration Utility (NCU).  Relying on Link Loss is all you should need, as long as SmartLink is enabled.




Additional comments? Are you using NIC teaming successfully?

Trusted Contributor

Re: Cannot configure NIC Teaming with VC private network configured.

 From Ken:


I suggest that an active/active VC design would address this issue.  The 2 NICs should be able to see each other through the upstream switch.