Comware-Based
Showing results for 
Search instead for 
Do you mean 

A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

SOLVED
Go to Solution
Highlighted
Occasional Visitor

A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

[ Edited ]

Hello everyone,

I am familliar a bit to IP networks but not really to deep router configuration neither Comware equipments.
Currently, I have to interconnect two existing sites – let's call them P and V – to create a small campus.

Both sites have similar VLANs – with same IDs –and each VLAN should be communicating with same-ID-VLAN on the opposite site.

To simplify, I isolated the kind of configuration I would like to – try – to deploy on core router of P and V, and also made a small draw, attached, for one sample VLAN (each VLAN config are more or less similar to this one).

 

# P site (10.0.31.0/24)
sysname P-Router

interface Vlan-interface103
 ip address 10.0.31.254 255.255.0.0 

vlan 103
 description my vlan 103
 name my_vlan_103

ip route-static 10.0.33.0 255.255.255.0 10.0.33.254 description to V.103

interface GigabitEthernet1/0/1
 port link-mode bridge
 description Device P1
 port access vlan 103

interface GigabitEthernet1/0/25
 port link-mode bridge
 description *to V-Router*
 port link-type trunk
 port trunk permit vlan all
# V site (10.0.33.0/24)
sysname V-Router

interface Vlan-interface103
 ip address 10.0.33.254 255.255.0.0 

vlan 103
 description my vlan 103
 name my_vlan_103

ip route-static 10.0.31.0 255.255.255.0 10.0.31.254 description to P.103

interface GigabitEthernet1/0/1
 port link-mode bridge
 description Device V1
 port access vlan 103

interface GigabitEthernet1/0/25
 port link-mode bridge
 description *to P-Router*
 port link-type trunk
 port trunk permit vlan all

Questions / Notes :
- I set enlarged subnets to Routers to make communication possible between each subnets, on same the VLAN over both sites
- Connection port between routers are in link-mode brige, would it be better in link-mode route instead (as different sites) ?
- There is extra configuration I ommited here (spanning tree per site, link aggregation, acls, inter-vlan routing per site, etc.)
- Does my configuration seems correct (enlarged subnet on routers + trunk link + static route)?

Many thanks for your advices,

Regards,
Julien

 

8 REPLIES
Advisor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

Hi,

I would suggest you create a point to point link using the link-mode route feature and have a couple of routing statements in place and have the VLANS operate separately, this way you dont have to worry about spanning tree.  

Honored Contributor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

[ Edited ]

If the purpose of using same VLAN Ids on both of your two switches is to let them interconnect (via a trunk which will permit all/some VLAN Ids) their own hosts (belonging to same VLAN) together without apply any IP Routing...which is a good and understandeable purpose...shouldn't you use the exact same IP Subnet for each VLAN Id on every Switch involved avoiding to be forced to do routing between differents subnets (10.0.31.0/24 and 10.0.33.0/24)?

Or, in other terms, if you'r desire is to span the same VLAN Id(s) across your two switches and to avoid doing routing "within" the same VLAN Id(s) (consider you configured VLAN 103 on V and VLAN 103 on P, in your case)...you should use the same (and only) subnet for each VLAN defined, no matter if (or better: exactly because) it spans on multiple switches.

Advisor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

[ Edited ]

Hi,

I find it a little bit confusing that you use a bigger subnet in the same VLAN for routing purposes. Otherwise I believe that it would work that way. You could think about a different VLAN between the two A5500 just for routing with an own subnet. The devices in the VLAN103 still have the same default gateway but the static routes between the two switches are (imo) more understandable. (I was confused at first, about why you would route in a single /16 network)

Occasional Visitor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

@KSHKND

I would suggest you create a point to point link using the link-mode route feature and have a couple of routing statements in place and have the VLANS operate separately, this way you dont have to worry about spanning tree.

Thanks for your comment. I had the same this idea actually also and I just tried today and it looks like link-type trunk is not compatible witht the link-mode route, only the link-mode bridge mode seems to accept trunking and pass the 802.1q tags through the link.

So I am disabled the spanning tree via command on my interface stp disable on my intersite link and it does the job.

Occasional Visitor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

@parnassus

If the purpose of using same VLAN Ids on both of your two switches is to let them interconnect (via a trunk which will permit all/some VLAN Ids) their own hosts (belonging to same VLAN) together without apply any IP Routing...which is a good and understandeable purpose...shouldn't you use the exact same IP Subnet for each VLAN Id on every Switch involved avoiding to be forced to do routing between differents subnets (10.0.31.0/24 and 10.0.33.0/24)?

Or, in other terms, if you'r desire is to span the same VLAN Id(s) across your two switches and to avoid doing routing "within" the same VLAN Id(s) (consider you configured VLAN 103 on V and VLAN 103 on P, in your case)...you should use the same (and only) subnet for each VLAN defined, no matter if (or better: exactly because) it spans on multiple switches.

I agree here; the things is that there is maybe something like 10 switches per site with maybe 6-7 vlan. On each vlan there is decades and decades of equipements on which we would need to change IP, subnet and gateway. And some servers have configuration with IP adresses...

We do not have resources to do this subnet change, so the temporary solution would be the one I presented above AND in a second time, we are planning to migrate the IP subnets.

Occasional Visitor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

@Linkk

I find it a little bit confusing that you use a bigger subnet in the same VLAN for routing purposes. Otherwise I believe that it would work that way.

I tested today, and actually... it works!

You could think about a different VLAN between the two A5500 just for routing with an own subnet. The devices in the VLAN103 still have the same default gateway but the static routes between the two switches are (imo) more understandable. (I was confused at first, about why you would route in a single /16 network)

What would you propose here: creating one new vlan per vlan to route between sites, or creating a global vlan and forward all traffic from / to this global vlan?

I have to repeat the design on several vlans, enlarging the subnet seems easier compared to new vlan(s) creation.

It would look like to add some piece of configuration like the bellow?

# P site (10.0.31.0/24)

interface Vlan-interface203
 ip address 10.255.203.1 255.255.255.252 

vlan 203
 description incomming traffic to Vlan 103
 name interco-my_vlan_103

ip route-static 10.0.31.0 255.255.255.0 10.255.203.1 description to V.203

# sans oublier de retirer la route précédente:
# undo ip route-static 10.0.31.0 255.255.255.0 10.0.31.254
# V site (10.0.33.0/24)

interface Vlan-interface203
 ip address 10.255.203.2 255.255.255.252 

vlan 203
 description incomming traffic to Vlan 103
 name interco-my_vlan_103

ip route-static 10.0.33.0 255.255.255.0 10.255.203.1 description to P.203

# sans oublier de retirer la route précédente:
# undo ip route-static 10.0.33.0 255.255.255.0 10.0.33.254

From your opinion, what is the advantage of this design instead (in addition to not have to change subnet mask on router & usage of different subnet size)?
Is it the "usual" way to route traffic between different subnets? (I am not used to router configuration design).

Thanks

Julien

Advisor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

[ Edited ]

The problem with your setup is, that you have kind of a hybrid between a switched and routed network. You will see, that you can give a client in Site P a static IP of site V and it will work, which is not usually wanted.

Also you probably encounter some DHCP problems, if both subnets have an active DHCP server. Because it is one big Layer 2 network, both DHCP servers will get the DHCP Discover packets. The client will then take the IP address of fastest response, which is usually the physically closest server, but it depends on the servers performance.

 

What would you propose here: creating one new vlan per vlan to route between sites, or creating a global vlan and forward all traffic from / to this global vlan?

I would do the second one. One VLAN for interconnection between all Routers, then add a route for every subnet to the new Vlan-Interface. And change the old VLAN (103) back to the original subnet mask (24) to prevent misunderstandings.

The link between your sites just needs the new interconnect VLAN and not the actual client VLAN.

Example:

# V site (10.0.33.0/24)
vlan 203 
description incomming traffic to Vlan 103
name interco-my_vlan_103
interface Vlan-interface203 ip address 10.255.203.2 255.255.255.252

interface vlan-interface103
ip address 10.0.33.254 255.255.255.0 ip route-static 10.0.33.0 255.255.255.0 10.255.203.1 description to P.203
ip route-static 10.0.X.0 255.255.255.0 10.255.203.1 describtion to P.X
[...]

interface GigabitEthernet1/0/25 port link-mode bridge description *to P-Router* port link-type trunk port trunk permit vlan 203
# P site (10.0.31.0/24)
vlan 203 
description incomming traffic to Vlan 103
name interco-my_vlan_103
interface Vlan-interface203 ip address 10.255.203.1 255.255.255.252 interface Vlan-interface103
ip address 10.0.31.254 255.255.255.0 ip route-static 10.0.31.0 255.255.255.0 10.255.203.1 description to V.203
ip route-static 10.0.Y.0 255.255.255.0 10.255.203.1 description to V.Y
[...]

interface GigabitEthernet1/0/25 port link-mode bridge description *to V-Router* port link-type trunk port trunk permit vlan 203

 

Occasional Visitor

Re: A5500 - Interconnecting VLAN from different 2 sites with different IP ranges

@LinkkVery clear, thank you! Now I have a quite good overview on how that should be done.

Thanks all for advices & comments, you helped me a lot.

Julien

//Add this to "OnDomLoad" event