Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Error msg in log of unified switch

DJokinen
Occasional Advisor

Error msg in log of unified switch

Hey,

 

I'm not sure where to post this since no forum seems to apply. I've got a network with 3Com PoE switches and since HP bought 3Com I haven't been able to find almost any info, firmware or anything. Hope you can help me to the right place or even better help me with my question.

 

This network is located in a 4 level building with 6 3Com 8760 AP's on each level. They're all PoE and connected to a smaller 10-port 3Com PoE switch on each level. They're then connected to a 3Com Unified Gigabit Wireless PoE 24-port switch in the basement, that manages all the AP's and their settings. There are a VMWare ESXi host with 2 Windows 2003 servers, each acting DHCP server for two of the vlans in the network. The third, "physical" network (vlan0) is managed by a router but is populated only by the AP's and other shared resources such as printers and a NAS for backups. There are about 200 - 250 simultaniously connected computers and smartphones at the most, divided on the two vlans.

 

Recently we've discovered that wirelessly connected units randomly lose connectivity. Looking at it in more detail, they actually drop their IP address, which of course drops them out of the network in a sense. Looking through the DHCP server logs it all looks fine. The request comes in, and the server answers. The response doesn't seem to get through back to the client though, so I've tried to rule out where it stops. I started with swapping out a few older switches and cables just to eliminate any possibility there, and then tried to go through the logs to get an idea of what's happening. Going through the logs in the unified switch, I found this;

 

01-Feb-2012 08:29:08   Debug   %OS-D-MEMORY: No free memory: size = 104, pool = SOCKdat, task = SOCK

 

This msg repeats itself 173 times within 9 seconds (!). I have no idea what it means, so I'd love any help with this. Also, I'm not sure wheater it's a coincidence or not yet, but wireshark seems to die in a runtime error when this error shows in the log. The error is shown in the log even if wireshark isn't on though, so it's not wireshark causing it. But it makes analysing the traffic difficult if I can't get a good log of it.

 

I have full documentation of the network layout, IP's and the whole setup if needed. But initially I'd be happy just knowing what that debug message means. Thanks!

 

 

P.S. This thread has been moved from Communications, Wireless (Legacy ITRC forum) to Comware-Based. -HP Forum Moderator

1 REPLY
DJokinen
Occasional Advisor

Re: Error msg in log of unified switch

Alright, so I managed to reach an HP support tech and sent him logs and stuff, and got a firmware update correcting memory leaks back. Unfortunally this didn't help, but he gave me some ideas about what's causing this. His throughts were that the spanning tree protocol (STP) is re-analysing the network to decide master role due to some unit in the network rebooting intermittently.

 

I have absolutly no idea what unit that would be, but I'm suspecting the ESXi host and the virtual switch. We had a problem with that not letting traffic through a couple of weeks ago so I had to delete it and create a new one. Seems only logical it'd be the root. Not sure how to look that up, so I guess I'll reinstall them all and see what happens.

 

I'll post back with the solution once I have it.