HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to switch

 
SOLVED
Go to solution
markscholman
Occasional Visitor

Failed to switch

Hi,

I have a 7904 switch (2 in an irf).

When i run the command to set an interface to route mode i got the error failed to switch. Can someone explain what i am doing wrong here or what i missed? I enabled it successful on 5900 switches.

[MYSW01-Ten-GigabitEthernet2/1/0/23]port link-mode route
Failed to switch.

Thank you

Mark

5 REPLIES
Ian Vaughan
Honored Contributor

Re: Failed to switch

Hello,

I can't remember seeing that message before. The 7900's and 12900's are a bit different to the rest of the Comware boxes and seem to have their own rules and guidelines - are you running your switch in a particular operating mode and does this mode support routed interfaces?

Anything in the syslog? Did it throw up any traps?

Can you "default" the interface first to strip any existing configuration from it before trying the switching modes again?

Let us know what you find out. We can then put some tags on the thread to make it easier to find if anyone comes looking for the same issue in the future.

Many thanks

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me
parnassus
Honored Contributor
Solution

Re: Failed to switch

Hi Mark,
 
Directly from the HPE FlexFabric 7900 Switch Series Layer 2 - LAN Switching Command Reference guide (valid since R215x release)...available here:
 
port link-mode
 
Use port link-mode to change the link mode of an Ethernet interface.
Use undo port link-mode to restore the default.
 
Syntax
 
port link-mode {bridge|route}
undo port link-mode
 
Default
 
Ethernet interfaces operate in bridge mode.
 
Views
 
Ethernet interface view
 
Predefined user roles
 
network-admin
mdc-admin
 
Parameters
 
bridge: Specifies the Layer 2 mode.
route: Specifies the Layer 3 mode.
 
Usage guidelines
 
On the switch, Ethernet interfaces can operate either as Layer 2 or Layer 3 Ethernet interfaces (you can use commands to set the link mode to bridge or route).
 
Each of the Layer 3 interfaces and subinterfaces use one VLAN interface resource. Before configuring an Ethernet interface to operate in route mode, use the reserve-vlan-interface command to reserve a VLAN interface resource for the interface. Otherwise, the operation might fail. For example, before configuring four Layer 2 interfaces to operate in route mode, you must reserve four VLAN interface resources by using the reserve-vlan-interface command.
 
To reserve global VLAN interface resources, specify the global keyword in the reserve-vlan-interface command. To reserve local VLAN interface resources, do not specify the global keyword. Reserved VLAN interface resources are local in this chapter.
 
For more information about reserving VLAN interface resources, see Layer 2 - LAN Switching Configuration Guide (cited above).
 
After you change the link mode of an Ethernet interface, all the commands (except the shutdown command) on the Ethernet interface are restored to their defaults in the new link mode.
 
Examples
 
# Configure FortyGigE 1/0/1 to operate in bridge mode.
<Sysname> system-view
[Sysname] interface fortygige 1/0/1
[Sysname-FortyGigE1/0/1] port link-mode bridge
# Configure FortyGigE 1/0/1 to operate in route mode.
<Sysname> system-view
[Sysname] reserve-vlan-interface 3000
[Sysname] interface fortygige 1/0/1
[Sysname-FortyGigE1/0/1] port link-mode route
So maybe (if Enhanced IRF is not a stopper for the port link-mode feature to work [*]) the VLAN interface resource reservation could be the key point for a successfull port link-mode implementation.
 
[*] I recall I've read on H3C Documentation of H3C S12500 Switch Series (OK, it's another iron and another brand) that Ethernet interfaces do not support switching the operating mode when they are member ports of/used into/ports of a Switch:
  • Aggregation groups.
  • Reflector port of a remote source mirroring group.
  • operating in IRF mode and with enhanced IRF enabled.
markscholman
Occasional Visitor

Re: Failed to switch

The trick was the reserve-vlan-interface setup.

Thanks a lot!

Mark

parnassus
Honored Contributor

Re: Failed to switch

Great!

Ian Vaughan
Honored Contributor

Re: Failed to switch

Good to know about the resource reservation for the route ports. 

Thanks for that.

Everyday is a schoolday on these forums, always learning something.

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me