Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

How to connect IP Phone and computer to 1 port on hp switch

pini_elbaz
Visitor

How to connect IP Phone and computer to 1 port on hp switch

Hi Every body!

 

i got a new project that contain HP 5500HI Switchs.

the topology product include connecting IP Phone to the switch and connect the pc to the ip phone (the ip phone is Alcatel Vendor).

 

i tried to configure the voice vlan in automacic mode and manual mode.

i tried to configure the interface to Hybrid mode and configure the voice vlan as tag vlan and the data vlan as untagged vlan and the pvid to data vlan.

i tried to set the mac address of the vendor id to the voice vlan but nothing is work correctly.

according to the mac address table of the switch, the pc and the phone got the same vlan.

 

anybody can help me with the correct syntax of the configuration?

 

the current configoration is:

 

[Test_Switch]display current-configuration
#
sysname Test_Switch
#
lldp enable
#
radius scheme system
#
domain system
#
vlan 1
#
vlan 10
name Data
#
vlan 20
name IPT
#
interface Aux1/0/0
#
interface Ethernet1/0/1
poe enable
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 10 untagged
undo port hybrid vlan 1
port hybrid pvid vlan 10
#
interface Ethernet1/0/2
#
interface Ethernet1/0/3
#
interface Ethernet1/0/4
#
interface Ethernet1/0/5
#
interface Ethernet1/0/6
#
interface Ethernet1/0/7
#
interface Ethernet1/0/8
#
interface Ethernet1/0/9
#
interface Ethernet1/0/10
#
interface Ethernet1/0/11
#
interface Ethernet1/0/12
#
interface Ethernet1/0/13
#
interface Ethernet1/0/14
#
interface Ethernet1/0/15
#
interface Ethernet1/0/16
#
interface Ethernet1/0/17
#
interface Ethernet1/0/18
#
interface Ethernet1/0/19
#
interface Ethernet1/0/20
#
interface Ethernet1/0/21
#
interface Ethernet1/0/22
#
interface Ethernet1/0/23
#
interface Ethernet1/0/24
#
interface GigabitEthernet1/1/1
#
interface GigabitEthernet1/1/2
#
interface GigabitEthernet1/1/3
#
interface GigabitEthernet1/1/4
#
undo irf-fabric authentication-mode
#
interface NULL0
#
voice vlan mac-address 0080-9f00-0000 mask ffff-ff00-0000
voice vlan 20 enable
#
user-interface aux 0 7
user-interface vty 0 4
#
return

 

 

Thanks,

Pini Elbaz

6 REPLIES
BenCramphorn
Occasional Visitor

Re: How to connect IP Phone and computer to 1 port on hp switch

We have IP Phones and Workstations daisy chained from the same port.

 

Port > Phone > Computer.

 

Our phone VLAN is 4001 and the PCs are currently on the default vlan. Our port config is as follows:

 

 port link-type hybrid
 port hybrid vlan 4001 tagged
 port hybrid vlan 1 untagged
 poe enable
 stp edged-port enable
 qos trust dscp

 

I'm fairly new to configuring switches so can't really give much advice outside of this but hopefully this helps.

pini_elbaz
Visitor

Re: How to connect IP Phone and computer to 1 port on hp switch

do you need to use some options on the DHCP Server when you use this configuration?

Vince-Whirlwind
Honored Contributor

Re: How to connect IP Phone and computer to 1 port on hp switch

You will need something on the interface that tells the phone what the Voice VLAN is,eg,

 

lldp voice vlan 20

 

Are you sure you need "hybrid"? Do you know what it does/what purpose it serves? (I don't. No other vendor seems to think it serves a purpose or they would offer it as well).

BenCramphorn
Occasional Visitor

Re: How to connect IP Phone and computer to 1 port on hp switch

Regarding DHCP then I guess that's down to how your phone needs to be set up.

 

We have a separate DHCP scope for each VLAN and when we configure our phones we SSH to the phone and have to set the VLAN and various other config settings it will be using. I believe the DHCP options for our phone VLAN include an option pointing to the phone management server although I'm not at work at the moment so can't check. 

 

And Vince, a hybrid port is basically one that allows tagged traffic AND untagged traffic. If traffic hits the port that's untagged it will assign it the VLAN you set on the port config untagged line. For example:

 

 port hybrid vlan 1 untagged

 

Any untagged traffic that hits the port is assigned to vlan 1 

Trackhappy
Occasional Visitor

Re: How to connect IP Phone and computer to 1 port on hp switch

For what it is worth, here is some of the config from one of our edges switches with Cisco IP phones and authenticated PC's:

 

Switch confi:

 voice vlan aging 100
 voice vlan track lldp
lldp compliance cdp
port-security enable

 

Portconfig:
 description poe_voip_45 (We have different vlans for different floors)
 port link-type hybrid
 port hybrid vlan 1 390 untagged
 port hybrid pvid vlan 390
 voice vlan 45 enable (Sets the voice vlan for things like QOS I gather)
 mac-vlan enable
 poe enable
 stp edged-port enable
 mac-authentication guest-vlan 390
 lldp compliance admin-status cdp txrx
 lldp voice-vlan 45 (I think this is where the vlan is set for the Cisco pphones)
 port-security port-mode mac-else-userlogin-secure-ext (we use mac auth for our PC's)
 dot1x guest-vlan 390
 dot1x auth-fail vlan 391 (This vlan goes into the bit bucket)

 

 

Make sure you have the latest firmware on there as we had issues with earlier versions. On your DHCP scope, you may need an option set that tells the VOIP phone where the control server is. Option 150 if I recall for the Cisco phones.

 

Hope that helps.

 

 

Trackhappy
Occasional Visitor

Re: How to connect IP Phone and computer to 1 port on hp switch

You could try this:

 

Global config:

 voice vlan aging 100
 voice vlan track lldp
 lldp compliance cdp

 

Port config:
 description poe_voip_20
 poe enable
 stp edged-port enable
 port link-type hybrid
 port hybrid vlan "10" untagged
 port hybrid pvid vlan "10"
 voice vlan "20" enable
 mac-vlan enable (not sure that you need this line in your config)
 lldp compliance admin-status cdp txrx
 lldp voice-vlan 20

 

If the phones support LLDP, it should work. Turn on term mon to help diagnose. I use hybrid by default but you don't have to. Let us know how you go.

 

Looks as though there may be "peculiarities" with Alcatel and DHCP, here is a link in case you need it.

http://www.alcatelunleashed.com/viewtopic.php?t=22167

 

BTW, I hate manually configuring each phone, so I always use DHCP etc. so a phone can be connected without any further intervention on the network side.