Comware Based

help with configure dhcp server on 5510 switch

 
EliEli
Occasional Contributor

help with configure dhcp server on 5510 switch

hi, 

i  need to configure dhcp server on 5510 switch, to Cisco ip phone.

this is the config that i was configure, but in fact, it's doesn't work.

help.. someone

dhcp server ip-pool 1
gateway-list 1.1.1.254
network 1.1.1.0 mask 255.255.255.0
address range 1.1.1.1 1.1.1.10
dns-list 2.2.2.1 2.2.2.2
domain-name test.co.il
expired day 8
option 150 ip-address 8.8.8.8 9.9.9.9
voice-config voice-vlan 7 enable
#
interface NULL0
#
interface Vlan-interface7
ip address 1.1.1.250 255.255.255.0
dhcp server apply ip-pool 1
#
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type hybrid
port hybrid vlan 1 untagged
voice-vlan 7 enable
stp edged-port
poe enable
#

thanks

 

5 REPLIES 5
jmpk
HPE Pro

Re: help with configure dhcp server on 5510 switch

Hi @EliEli 

So if i understand that your Cisco IP is not receving the DHCP ip address from 5510 switch ?  From your config i could see that you have enabled the Voice VLAN, but you have to untag the voice VLAN and tag the data VLAN . 

Also add following commands and check the response 

lldp compliance admin-status cdp txrx
cdp voice-vlan 7

You can also refer HPE FlexNetwork 5510 HI Switch SeriesLayer 2—LAN SwitchingConfiguration Guide from below link and see section 'Configuring voice VLANs' on pg. 173.

https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c04904726


I work for HPEAccept or Kudo
EliEli
Occasional Contributor

Re: help with configure dhcp server on 5510 switch

Hi,

I was add the 2 commands of CDP and the phone still doesn't get the ip from the dhcp server. (the dhcp server is locly on the switch that the Ciscp phone connected to)

I didn't understand about what you wrote to me: "you have to untag the voice VLAN and tag the data VLAN"

how can i untag the voice vlan?

jmpk
HPE Pro

Re: help with configure dhcp server on 5510 switch

Hi @EliEli 

Are you using both data and voice VLAN in single port ? If so please tagg the voice VLAN and untagg the data VLAN ( my pervious statement about tagg and untagg is wrong ) . Also in you configuration you have enabled only the voice Vlan 7, but not tagged or untagged in interface.

Please share your feedback once you performed the above suggestion 

Below is the config for your  reference 

interface GigabitEthernet1/0/1
 description HYBRID PORT
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan 49 tagged
 port hybrid vlan 831 untagged
 port hybrid pvid vlan 831
 voice-vlan 49 enable
 lldp compliance admin-status cdp txrx
 poe enable
 lldp global enable
 lldp compliance cdp


I work for HPEAccept or Kudo
EliEli
Occasional Contributor

Re: help with configure dhcp server on 5510 switch

Hi,

Yes, i am using both data and voice VLAN in single port.

Unfortunately, the phone still don't get ip address from the dhcp server.

This is my confoguration:

version 7.1.045, Release 1121
#
sysname HPE
#
voice-vlan track lldp
#
lldp global enable
lldp compliance cdp
#
vlan 1
#
vlan 2
#
vlan 7
#
stp global enable
#
dhcp server ip-pool 1
gateway-list 1.1.1.254
network 1.1.1.0 mask 255.255.255.0
address range 1.1.1.1 1.1.1.10
dns-list 2.2.2.1 2.2.2.2
domain-name test.co.il
expired day 8
option 150 ip-address 8.8.8.8 9.9.9.9
voice-config voice-vlan 7 enable
#
interface Vlan-interface7
ip address 1.1.1.250 255.255.255.0
dhcp server apply ip-pool 1
#
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type hybrid
port hybrid vlan 7 tagged
port hybrid vlan 1 to 2 untagged
port hybrid pvid vlan 2
undo voice-vlan mode auto
voice-vlan 7 enable
stp edged-port
lldp compliance admin-status cdp txrx
cdp voice-vlan 7
poe enable
#

jmpk
HPE Pro

Re: help with configure dhcp server on 5510 switch

Hi @EliEli 

This is strange , this may required complete analsysis of log. I suggest you to log a support case with HPE s


I work for HPEAccept or Kudo