Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

[possible bug] DHCPv6 relay setup

 
MichaelM55
Trusted Contributor

[possible bug] DHCPv6 relay setup

Hi,

I think I found a bug. Perhaps someone could verify this:


switch: H3C S5500-EI (HP A5500-EI)
firmware: Software Version 5.20 Release 2210
setup: stateful DHCPv6 relay

DHCPv6 server: Windows 2008 R2


vlan 1234
ipv6 dhcp snooping vlan enable

interface Vlan-interface1234
 ipv6 nd ra prefix 2001:1234:300:100::/64 360 300 no-autoconfig off-link
 undo ipv6 nd ra halt
 ipv6 nd autoconfig managed-address-flag
 ipv6 nd autoconfig other-flag
 ipv6 address 2001:1234:300:100::BA/64
 ipv6 dhcp relay server-address 2001:1234:300:20::100

 



So, Windows 7 gets the IPv6 address:

    IPv6 Address. . . . . . . . . . . : 2001:1234:300:100::925f(Preferred)
    Default Gateway . . . . . . . . . : fe80::4201:c6ee:fe80:2501%11

 


First, I cannot "ping -6" anything.

Then I "ping -6 fe80::4201:c6ee:fe80:2501:2501", so the link local address of the switch.

After that I can "ping -6" everything.


Without pinging the link local address first, I cannot ping anything else?

Strange? For sure. So, is it a bug? (Windows 7 has its default settings:  netsh interface ipv6 reset)

 

==========================================================

Next test:

 

Let´s do an ipconfig /release6 and ipconfig /renew6 afterwards. Do an "ipv6 dhcp snooping user-binding dynamic" on the switch and reconnect.

 

result: ping -6 works without pinging the link local address of the switch, first.

 

 

==========================================================

 Next test:

 

- Take another laptop and connect it

- laptop gets IPv6 address

- "ping -6" something fails

- "ping -6" the link local address works.

- "ping -6" something else fails???

 

Now I´m confused...

 

 

Perhaps an issue with Windows 7?