Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

"port link-mode route"

MichaelM55
Trusted Contributor

"port link-mode route"

Hi,

 

is there a practical difference between using a routed interface and applying bridged interface with added vlan for routing purposes?

 

i.e.

 

interface gig 1/0/1
port link-mode route
ip address 10.1.1.1 255.255.255.252

versus

interface gig 1/0/1
port link-mode bridge
port link-type hybrid
port hybrid vlan 1 untagged

interface vlan-interface 1
ip address 10.1.1.1 255.255.255.252

 

6 REPLIES
manuel.bitzi
Trusted Contributor

Re: "port link-mode route"

No, not really. Because a bridge interface is internally handeled the same as the vlan interface. The differents is, that a vlan interface can applied to multiple multiple ports. Could be a advantage and an disadvantage. :-)

 

br

Manuel

H3CSE, MASE Network Infrastructure [2011], Switzerland
rda
Occasional Advisor

Re: "port link-mode route"

My general preference is routed ports.

 

Good discussion on topic, cisco focused, but the concepts still apply.

http://www.networking-forum.com/viewtopic.php?f=33&t=21253

 

Cheers,

 

Dan

Peter_Debruyne
Honored Contributor

Re: "port link-mode route"

Hi,

 

The advantage of a routed port is that it is not considered a switch port, so e.g. stp will automatically not run on the port (no L2 broadcasts are passing the interface).

 

The other advantage is that in case you want to pass multiple IP interfaces over 1 physical interface, vlan tags are required on the interface (in case you would be using VRFs for instance). In that case, the vlan interface would work, but the vlan id is allocated at the switch global level, so cannot be used on other interfaces anymore (that vlan would be L2 switched inside the switch). In the case of a routed port, a subinterface with a vlan tag can be created, and this vlan tag is interface local, so has nothing to do with the global vlans. So you could have 2 routed ports,each with mutiple IP interfaces on them via the subinterfaces, and the subinterface of interface1 could use vlan tag 10, while at the same moment a subinterface of interface 2 could also be using vlan tag 10. And these 2 subinterfaces would not be interconnected at layer2 (since there is no global vlan 10 required for the subinterface to work).

 

That is the theory, however on most HP L3 switches, these subinterfaces are not (yet ?) supported, the routers have full support for it.

 

Best regards,Peter

 

MichaelM55
Trusted Contributor

Re: "port link-mode route"

Thanks for all of your answers.

 

(I´m happily running Virtual Routing Instances (VRF/H3C "MCE") on my 3Com 4800G == HP E4800 == H3C S5500-EI == HP A5500-EI switches for years)

Pete W
Valued Contributor

Re: "port link-mode route"

I realise that this post was a long time ago - but what version of code are/were you running.

 

Regards,

 

Pete

HPE MASE
Aruba ACMP
Fortinet NSE 1-7
Cisco CCNP
keyboardz_21
Occasional Contributor

Re: "port link-mode route"

Hi,

 

can you pass vlan interfaces on the routing port like the below config

 

interface Vlan-interface64
description CORE_NEW
ip address 10.106.64.1 255.255.255.0
#
interface Vlan-interface65
description DMZ_3
ip address 10.106.65.1 255.255.255.0
#
interface Vlan-interface66
description PRODUCTION_NEW
ip address 10.106.66.1 255.255.255.0

 

interface GigabitEthernet1/0/0/21
port link-mode route
ip address 172.16.200.2 255.255.255.0 

 

---connected to a firewall 172.16.200.1