cancel
Showing results for 
Search instead for 
Did you mean: 

Apache:OWA problem

Shailesh_6
Occasional Contributor

Apache:OWA problem

Hi,
I am using
apache_1.3.14
perl-5.6.1 (no thread)
mod_perl-1.26
DBI-1.23
oracle 8.1.7 32 bit.
hpux 11.00
ansi c

I have complied all and when testing OWA. I get this error message.

Out of memory!
Callback called exit.

After putting debug stmt in OWA.pm I found out that it fail at:
if ($owa_version{$uri} <= 768) {
$sql ='
line number 295.

If I remove the check it finally fail at

$sth->bind_param_inout(':content', \$content, { TYPE => 24 } );

With same error message.

Can anybody help me?

I tried with DSO as well as static linking of mod_perl, it gives same error.

Should I enable threads in perl?

Thank you in advance.

Shailesh
2 REPLIES
Shailesh_6
Occasional Contributor

Re: Apache:OWA problem

Hi,
I recompiled perl again with malloc option enable. Now I got this error message

[Mon Jun 3 22:03:12 2002] [warn] executed OK
[Mon Jun 3 22:03:12 2002] [error] Out of memory during "large" request for 2147
487744 bytes, total sbrk() is 1705984 bytes at /user2/aruba/perl5/lib/site_perl/
5.6.1/Apache/OWA.pm line 347.

Which is

$sth->bind_param_inout(':content', \$content, { TYPE => 24 } ); # varchar2

Thank you in advance

Shailesh
Steve Post
Trusted Contributor

Re: Apache:OWA problem

I didn't look into your details. But the words "OUT OF MEMORY" chimed out like a beacon in the night.

My guess has little to do with apache.
Run swapinfo -tm to check on swap memory.
Look in /var/adm/syslog/syslog.log to see if you had any errors.

I have apache running on a box with mod_perl. And recently I also had out of memory errors. The usage of the web sites increased. This resulted in more memory usage. I ran swapinfo -tm, and saw 100% for the "total" line. From talking to HP, I did not have pseudo swap enabled. Enabling it drastically increased my memory available.

Maybe this is your problem?