Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

DBI-1.40, DBD-1.13 w/ Oracle 8.1.6 Can't find library "nbeq8"

Midrange Systems Unix
Occasional Contributor

DBI-1.40, DBD-1.13 w/ Oracle 8.1.6 Can't find library "nbeq8"

I have installed DBI 1.40 successfully.

Now when I attempt to install DBD it fails with:
/usr/ccs/bin/ld: Can't find library "nbeq8"

ORACLE_HOME=/u001/app/oracle/product/8.0.6
LD_LIBRARY_PATH=/u001/app/oracle/product/8.0.6/lib:/usr/lib:/u001/app/oracle/product/8.0.6/rdbms/lib
SHLIB_PATH=/u001/app/oracle/product/8.0.6/lib:/usr/lib

PERL = 5.6.1.E
gcc = 3.3.2
DBI = 1.40
DBD = 1.13

Thanks for nay help provided.
1 REPLY
A. Clay Stephenson
Acclaimed Contributor

Re: DBI-1.40, DBD-1.13 w/ Oracle 8.1.6 Can't find library "nbeq8"

libnbeq8 is actually available as libnbeq8.a (i.e. an archived libraries) and is thus a static link. SHLIB_PATH will have no effect on this.

cd ${ORACLE_HOME}
find . -name '*beq8*'

If the library is found, you have a prayer. I assume this is done in a makefile, so change your makefile so that LDPATH includes this library's location or simply explicitly use the entire path (e.g. /xxx/yyy/zzz/libnbeq8.a) rather than the "shorthand" version -lnbeq8 which the linker then expands for you.
If it ain't broke, I can fix that.