cancel
Showing results for 
Search instead for 
Did you mean: 

Getting oci8 to work.

Dragoa
Occasional Visitor

Getting oci8 to work.

Hello,

I am currently fairly new to the HP-UX environment and I'm trying to get oci8 functioning on an Itanium 2 machine using the pre-compiled HP package. I've tried following a tutorial posted on the forums earlier, but it seems a bit dated and hard to follow since it talks about a bunch of extensions and build options that I have no idea if they apply to me or not, and even after shifting out what I'm supposed to be adding, it still doesn't function.

I'm not to sure where to start in explaining the problem, but I know that PHP is not loading in the oci8 module, and I've already ensured that the php.ini file is supposed to be loading it, and that the extension_dir is correct.

The version of Oracle I'm trying to interface with is 10.2.3(Itanium2 Build), and Oracle Instant Client 10.2.2(Default, it worked on the old HP-UX 11 machine, is about all I know about it)

I'll post anything I can to help, but I'm not sure what to post to start this off, any sort of direction would be greatly appreciated.

Thanks,

Dave
4 REPLIES
Tim Nelson
Honored Contributor

Re: Getting oci8 to work.

Did you read though this and all the user contributed tips at the end ?

http://us2.php.net/manual/en/oci8.setup.php

Dragoa
Occasional Visitor

Re: Getting oci8 to work.

Just read through them and I'm trying not to install anything, since that leads me into a whole different slew of problems with missing files and compilers not functioning properly. Unfortuantly, most of that page doesn't really help me it talks about re-building PHP which I am currently not at liberty to do.

From what I can tell, the oci8.sl module is just not being included by the PHP server, since when I try to run my page is says "oci_connect" is not defined. And I just did a test to make sure that my php.ini file is being correctly read it and it reads in ftp.sl just fine(from phpinfo() I see that ftp is enabled, but I don't see anything about oci8 despite having that extension module unchecked as well)
Dragoa
Occasional Visitor

Re: Getting oci8 to work.

Got it! Now if only it worked...Turns out I needed to make a link for the libclntsh.so.9.0 file in the instantclient directory.
Dragoa
Occasional Visitor

Re: Getting oci8 to work.

Whoops. See above post for solution details...