BladeSystem Forums have moved here
To make BladeSystem information easier to find, we have moved the BladeSystem forums here, to Servers and Operating Systems.
Showing results for 
Search instead for 
Do you mean 

Oracle net broken after hostname change

Go to Solution
Trusted Contributor

Oracle net broken after hostname change

Not sure if this is Oracle or HPUX issue.


On a DR box running hpux 11.31, oracle v10.2.0.5. A hostname change is part of our DR test. After changing the system hostname (but not the IP address), Oracle listener will not start. Errors with TNS-12545: Connect failed because target host or object does not exist. The tnsping also fails wit the same message. As the oracle user - I can ping the system with its new hostname without a problem. If I edit the tnsnames and listener files to have the host's IP address - the listener starts, but with the hostname it does not. The hostname was changed by: editing the /etc/hosts file, editing the hostname in netconf to be the new hostname, doing set_parms hostname. I tried doing /sbin/init.d/hostname start - this did NOT work, so I used set_parms hostname.  Any ideas? Thanks

Trusted Contributor

Re: Oracle net broken after hostname change

Found the issue - set_parms changes the permissions on /etc/hosts to 600!. Changing permissions to 644 fixes the problem.

Honored Contributor

Re: Oracle net broken after hostname change

Are you perhaps using a custom "umask 077" for root?


I've been burned by this at least once before: some Oracle security patches did not consider that the oracle user might have a non-default umask, and relied on the default umask (022) instead of explicitly setting the permissions for new Oracle binaries and libraries. After the update, the applications could not access the Oracle libraries they needed, until the permissions issue was noticed and fixed.


Perhaps the set_parms script has a similar built-in assumption that the root's umask is 022, as is the HP-UX default?

Trusted Contributor

Re: Oracle net broken after hostname change

Apparently you are right - umask is set to 077. Thanks.