cancel
Showing results for 
Search instead for 
Did you mean: 

fs not mounting at boot

Jim Booker
Advisor

fs not mounting at boot

I have this line in my /etc/fstab...

/dev/oracle/oracle1 /opt/oracle vxfs rw,suid,largefiles,delaylog,datainlog 0 2

I will not mount at boot, however if
I simply do mount /dev/oracle/oracle1 /opt/oracle

it mounts. Any ideas???
9 REPLIES
linuxfan
Honored Contributor

Re: fs not mounting at boot

Hi Jim,


Was the VG /dev/oracle active when you tried to mount it or did you have to activate it?

Did you see any errors in /etc/rc.log?

-Ramesh
They think they know but don't. At least I know I don't know - Socrates
Sridhar Bhaskarla
Honored Contributor

Re: fs not mounting at boot

What does your rc.log say?.

Did you try doing a mount -a and see if
it is mouting?..

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
James R. Ferguson
Acclaimed Contributor

Re: fs not mounting at boot

Hi Jim:

Are you sure that /opt/oracle has 'largefiles' support enabled? Do this:

# fsadm -F vxfs /opt/oracle

This will return "largefiles" or "nolargefiles". If there is "nolargefiles" support and you are trying to mount with the 'largefiles' option, the mount will fail.

Regards!

...JRF...
David Manson
Occasional Advisor

Re: fs not mounting at boot

You could try checking the /etc/rc.log? Near the top you should see something like ...
Mount file systems
Output from "/sbin/rc1.d/S100localmount start":
Also worth checking the /var/adm/syslog/syslog.log for any messages relating to the mount operation.
Manju Kampli
Trusted Contributor

Re: fs not mounting at boot

I reckon the options mentioned in the /etc/fstab are not matching with the file system paramaeters. please check them

Hope this helps
Manju
Never stop "LEARNING"
Sanjay_6
Honored Contributor

Re: fs not mounting at boot

Hi Jim,

the /etc/rc.log file should tell you why that particular volume is not getting mounted. I'm assuming your Vg is getting activated at boot time, since you are able to mount the volume through the command prompt.

I had a similar situation where one particular volume was not getting mounted. On looking at /etc/rc.log file i found that the filesystem was set to mount with largefiles options while the filesystem was set as nolargefiles.

You can check that using,

fsadm -F vxfs /opt/oracle once you have mounted the filesystem. It should return with
"largefiles" if the same is set. If the same returns with "nolargefiles", you have two choices, either set the filesystem parameter to lrgefiles or in the /etc/fstab set the para as nolargefiles. I would prefer to have it set as largefiles.

You can do that either using SAM, Select Disk and Filesystems---> Filesystems, select the logical volume and in the action menu, select modify, modify the VXFS options, set the option to largefiles.

The other way is to unmount the filesystem and do it through fsadm
fsadm -F vxfs -o largefiles /dev/oracle/oracle

Hope this helps.

Thanks
Bill Hassell
Honored Contributor

Re: fs not mounting at boot

Whenever you make a change to fstab, always mount the location by hand. For the example given:

/dev/oracle/oracle1 /opt/oracle vxfs rw,suid,largefiles,delaylog,datainlog 0 2

the mountpoint is /opt/oracle, so use the command:

mount /opt/oracle

and see what the errors might be. I always test fstab with mount before rebooting.


Bill Hassell, sysadmin
T G Manikandan
Honored Contributor

Re: fs not mounting at boot

Hello,
For your /opt/oracle file system.
sam-->Disks and file systems-->Actions--->modify
check whether you have checked the mount at boot option.
!!Good replies for to check the large files on the file system.
Thanks
G Manikandan
Ravi_8
Honored Contributor

Re: fs not mounting at boot

Hi,
/dev/oracle/oracle1 /opt/oracle vxfs rw,suid,defaults 0 2
this will work.
never give up