cancel
Showing results for 
Search instead for 
Did you mean: 

fsadm error (On-Line JFS)

Seth Gustafsson
Occasional Advisor

fsadm error (On-Line JFS)

Getting this error when trying to expand a file system.

#fsadm -F vxfs -b 1228800 /home
fsadm: the -b option requires "HP OnLineJFS (Advanced Vxfs)"

As you can see below, I have On-Line JFS installed (Output from swlist)

2UserDegrade B.11.00 HP-UX 2-User License (For degrading user license level)
B2491BA B.11.00 MirrorDisk/UX
B3929BA B.11.00 HP OnLineJFS (Advanced VxFS)
B9788AA 1.3.0.00 Java 2 SDK 1.3 for HP-UX (700/800), PA1.1 + PA2.0 Add On
HPUXEng64RT B.11.00 English HP-UX 64-bit Runtime Environment
UXCoreMedia B.11.00 HP-UX Media Kit (Reference Only. See Description)
XSWGR1100 B.11.00.45 HP-UX Extension Pack, May 1999

Anybody have any ideas, how I can fix this.

Thank you

Dan Gustafsson

2 REPLIES
Ben Roller
Occasional Contributor

Re: fsadm error (On-Line JFS)

I recently had the same problem. I was instructed to reinstall the On-line JFS, and to repatc. Here is the e-mail pasted.
Hi Ben,

Here are the detailed instructions for fixing the problem on your system
that you requested.

Since the /usr/conf/lib/libvxfs_adv.a is not on your system the Advanced VxFS filesets need to be re-installed. You will have to set 'reinstall=true' option for swinstall to be able to re-install this product.

Please consider the following information when installing and patching Advanced VxFS (also known as Online JFS):

After you install or re-install Advanced VxFS on HP-UX 11.00, you must
ensure that the Advanced VxFS product is properly patched. Failure
to properly patch the application can lead to unexpected downtime,
file system corruption, and unexplained errors, caused by previously
resolved problems.

At HP-UX 11.00, you can re-apply the Advanced VxFS patches to
resolve the problem.

Perform the following steps after installing or re-installing Advanced VxFS
onto an HP-UX 11.0 system:

1. Install [PHKL_18543/PACHRDME/English] and its dependencies (even
if [PHKL_18543/PACHRDME/English] is already installed).

Note: Do not use the 'reinstall=true' option.
See PHKL_18543's Special Installation Instructions for
more information.

2. Install the remaining HP-UX 11.0 Advanced VxFS patches and their
dependencies. Again, Do Not Use the 'reinstall=true' option:

PHCO_20882 :fsck_vxfs:extendfs:corruption:
PHCO_21187 :SAM:ObAM:
PHKL_13203 :OnLineJFS:AdvancedVxFS:inode:corruption:
PHKL_15940 :Advanced:VxFS:vx_dmattr_tbl_init():OmniStorage:
PHKL_17038 :vmtrace:data:page:fault:
PHKL_20016 :G70:H70:I70:CPU:missing:
PHKL_20411 :panic:VxFS:snapshot:filesystem:
PHKL_20674 :unmount:MMF:VxFS:hangs:sync panics:
PHKL_21392 :VxFS:peformance:hang:icache:DPFs:
PHKL_22208 :OnLineJFS:VxFS:DMAPI:DPF:
PHKL_22589 :LOFS:select:IDS/9000:umount(1M):
PHNE_20949 :HyperFabric:B.11.00.0[0-8]:



Note: These patches, as with any patches, may be superseded.
Please check for the latest patches at the Electronic
Support Center (ESC) by using either of these web sites:


http://us-support.external.hp.com


http://europe-support.external.hp.com


Best regards,
Wayne.
Michael McCauley
Occasional Visitor

Re: fsadm error (On-Line JFS)

cd /stand/build
run:
/usr/lbin/sysadm/system_prep -s system

vi system and look for "vxadv", if it is not there add it and build a new kernal. If it compiles without error put it in place (kmupdate) and reboot.

You might have to install a patch. Check the patch database for the latest one.