Showing results for 
Search instead for 
Do you mean 

how do i disable async io in 11iv3

Go to Solution
Regular Advisor

how do i disable async io in 11iv3

Greetings all;

Installing 10gr2 on a 11iv3 rx6600 box. Oracle does not like async io enabled. How can I disable async io on the server. Did change /dev/async perms to 660. Is there something else I should do?

Thank you in advance for your responses.

Valued Contributor [Founder]

Re: how do i disable async io in 11iv3

You may need to set "fs_async" to 0.


Respected Contributor [Founder]

Re: how do i disable async io in 11iv3


This is a bug in Oracle bug ref 5359528

I don't know is you had to change the perms though.

I had this prob also but on an Itanium box of HPux and I found a note on metalink Oracle bug ref 5359528:

sql> alter system set disk_asynch_io=false scope=spfile;
Look before you leap

Re: how do i disable async io in 11iv3

The bug does not appear to have been fixed on Oracle  I've been diagnosing random application disconnects to the DB and found an Oracle alert log refering to trace files that had thousands of entries stating "Ioctl ASYNC_CONFIG error, errno = 1".


Below is the SQL I used to see that the Oracle setting was wrong, and also the SQL I used to change it to FALSE (as stated in the original post).  Note that you must bounce the database after making the change.



Connected to:
Oracle Database 11g Release - 64bit Production

SQL> show parameter disk_asynch_io;

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
disk_asynch_io                       boolean     TRUE


SQL> alter system set disk_asynch_io = false scope=spfile;


system altered


SQL> shutdown immediate;


SQL> startup;


... from the trailer park of the Milky Way.