Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
cancel
Showing results for 
Search instead for 
Did you mean: 

ninstall Error

prasathc
Frequent Advisor

ninstall Error

Hi All
I got one 9000/715/E machine, and it's OS is 10.20. when i try to execute /usr/adm/netdist/netdaemon.dy
to update the aliases database file it's giving the following error

like "ninstall: 17:57:03 ERROR ninstall/tcp is not in the services database"

I have made an entry in the /etc/services as "ninstall 2150/tcp"
eventhou it's giving the error message.

Can any one pls help me in this regard.

Thanks in Advance
4 REPLIES
Steve Steel
Honored Contributor

Re: ninstall Error

Hi

From readme

The following entry should be in your /etc/services file:

ninstall 2150/tcp

You should also have an entry in your /var/adm/inetd.sec file like this:

ninstall allow 15


Do you have both of these


steve Steel
If you want truly to understand something, try to change it. (Kurt Lewin)
prasathc
Frequent Advisor

Re: ninstall Error

In /var/adm/inetd.sec there is no entry like
ninstall allow 15. So i made an entry and then
inetd stop / start. But still it's giving the same error.

Anything aprt from this.

Prasath C
Steven Sim Kok Leong
Honored Contributor

Re: ninstall Error

Hi,

Perform further troubleshooting from the server itself:

1) Verify that the connection works:

# telnet localhost 2150

If the connection gets established, then the service is running at service TCP port 2150.

2) Test /etc/services:

# telnet localhost ninstall

If the connection gets connected, then your /etc/services is working properly in the translation of ninstall to service port 2150.

If the connection does not get connected, then either there is a typo in /etc/services or it is using an entirely different service database (though unlikely).

Hope this helps. Regards.

Steven Sim Kok Leong
Email: steven@beepz.com. Homepage: https://www.beepz.com
prasathc
Frequent Advisor

Re: ninstall Error

Hi
I have tried to
#telnet 2150
Trying...
telnet: Unable to connect to remote host: Connection refused

it's giving the following error

# telnet hpcvl055 ninstall
ninstall: bad port number
#

I don't know what to do now.
Can anybody help me out in this regard.

Thanks in Advance