cancel
Showing results for 
Search instead for 
Did you mean: 

Apche and PHP with mysql support

Madhu Kangara
Frequent Advisor

Apche and PHP with mysql support

I downloaded 64 bit Apache 2.0 depot from HP for IA64. Unfortunately I did not see extensions for Mysql.
mysql.sl file in php/extensions directory is missing.

The depot name is HPUXWS22ATW-B302-64.depot
Did HP removed support for Mysql from PHP?

Any fix?
13 REPLIES
smatador
Honored Contributor

Re: Apche and PHP with mysql support

Hi,
Mysql and oracle are supported with php.
Look the faqs
http://www.hp.com/products1/unix/webservers/apache/faqs/index.html#top
Steven E. Protter
Exalted Contributor

Re: Apche and PHP with mysql support

Shalom,

HPWS HP web suite ships fully capable of working with mysql. mysql needs to be installed separately but is available from http://software.hp.com

Its part of the Internet Suite from HP, ported from the open source versions.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Madhu Kangara
Frequent Advisor

Re: Apche and PHP with mysql support

Steven,
Even though FAQ, claims it has Mysql support, extensions are missing from the depot
[root@ctlpoc03:/opt/hpws/apache/php/lib/php/extensions]# uname -a
HP-UX ctlpoc03 B.11.31 U ia64 2555055672 unlimited-user license
[root@ctlpoc03:/opt/hpws/apache/php/lib/php/extensions]# ls -l
total 14190
-r-xr-xr-x 1 bin bin 76792 Oct 9 2006 crack.sl
-r-xr-xr-x 1 bin bin 490056 Oct 9 2006 dom.sl
-r-xr-xr-x 1 bin bin 171616 Oct 9 2006 ftp.sl
-r-xr-xr-x 1 bin bin 1031960 Oct 9 2006 gd.sl
-r-xr-xr-x 1 bin bin 968848 Oct 9 2006 ldap.sl
-r-xr-xr-x 1 bin bin 370672 Oct 9 2006 oci8.sl
-r-xr-xr-x 1 bin bin 3857824 Oct 9 2006 openssl.sl
-r-xr-xr-x 1 bin bin 164752 Oct 9 2006 sockets.sl
-r-xr-xr-x 1 bin bin 79632 Oct 9 2006 yp.sl
-r-xr-xr-x 1 bin bin 91576 Oct 9 2006 zlib.sl
Shinji Teragaito_1
Respected Contributor

Re: Apche and PHP with mysql support

As you installed Apache 2.2.8.01.02 from HPUXWS22ATW-B302-64.depot, you should check the /opt/hpws22 directory, not /opt/hpws.

Shinji
dirk dierickx
Honored Contributor

Re: Apche and PHP with mysql support

welcome to a world of pain. if you are going to AMP, just do it on linux.

even xampp has no hpux version available, it's hilarious!
Shinji Teragaito_1
Respected Contributor

Re: Apche and PHP with mysql support

# swlist | grep Apache
hpuxws22Apache B.2.2.8.01.02 HP-UX Apache-based Web Server
hpuxwsApache B.2.0.58.01 HP-UX Apache-based Web Server
# ll /opt/hpws22/apache/php/lib/php/extensions/
total 42320
-r-xr-xr-x 1 bin bin 375232 Dec 3 16:04 apc.sl
-r-xr-xr-x 1 bin bin 119784 Dec 3 16:04 crack.sl
-r-xr-xr-x 1 bin bin 4603240 Dec 3 16:03 dom.sl
-r-xr-xr-x 1 bin bin 161120 Dec 3 16:03 ftp.sl
-r-xr-xr-x 1 bin bin 4437960 Dec 3 16:04 gd.sl
-r-xr-xr-x 1 bin bin 138480 Dec 3 16:04 ldap.sl
-r-xr-xr-x 1 bin bin 2456280 Dec 3 16:03 mysql.sl
-r-xr-xr-x 1 bin bin 426568 Dec 3 16:03 oci8.sl
-r-xr-xr-x 1 bin bin 282632 Dec 3 16:03 openssl.sl
-r-xr-xr-x 1 bin bin 823576 Dec 3 16:03 pgsql.sl
-r-xr-xr-x 1 bin bin 7267880 Dec 3 16:03 soap.sl
-r-xr-xr-x 1 bin bin 122960 Dec 3 16:03 sockets.sl
-r-xr-xr-x 1 bin bin 48064 Dec 3 16:03 yp.sl
-r-xr-xr-x 1 bin bin 356912 Dec 3 16:03 zlib.sl
#
Roman Vasicek
Occasional Visitor

Re: Apche and PHP with mysql support

I have almost the same issue with HP-UX 11.11 on PA-RISC system. I've installed Apache and MySQL (Internet Express package mentioned as prerequisity for connecting to MySQL from PHP code).

hpuxwsApache B.2.0.59.12 HP-UX Apache-based Web Server (with IPv6 support)
hpuxwsTomcat B.5.5.27.02 HP-UX Tomcat-based Servlet Engine
web2 A.10.00-000 HP-UX Internet Express

I've enabled mysql extension in php.ini but I'm unable to connect to the database. I'm receiving error message "Can't connect to MySQL server on ...". The database server is up and running - I'm able to connect to it using command line client from the same box.

phpinfo() provide me with following:

MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.1.33
MYSQL_MODULE_TYPE no value
MYSQL_SOCKET /tmp/mysql.sock
MYSQL_INCLUDE no value
MYSQL_LIBS no value

Directive Local Value Master Value
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket no value no value
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off

Any ideas?
Roman Vasicek
Occasional Visitor

Re: Apche and PHP with mysql support

In my case it looks like an PHP error. We've tried to use tusc on httpd process handling the request. There is error EINPROGRESS returned from connect() call when the process is connecting to the MySQL database server...
dbwi
Occasional Visitor

Re: Apche and PHP with mysql support

Has a solution yet been found for this issue?

I am having the same problems as above, that is, I installed MySQL A.13.00-5.1.33.004 and there is no mysql.sl on my system.

Swverify confirms that the install was successful but I searched the entire system and there is no mysql.sl file.

Everything else in my HPWS seems to be working, i.e. apache and php.

Please help!
Shinji Teragaito_1
Respected Contributor

Re: Apche and PHP with mysql support

Which Apache version are you using ? Please give us the output from swlist.

% swlist | grep Apache
dbwi
Occasional Visitor

Re: Apche and PHP with mysql support

# swlist | grep Apache
hpuxwsApache B.2.0.58.00 HPUX Apache Web Server
dbwi
Occasional Visitor

Re: Apche and PHP with mysql support

I was able to resolve this problem by re-installing HPWS.

After installing HPWS the mysql.sl was back in the PHP extensions directory.

Thanks!
Roman Vasicek
Occasional Visitor

Re: Apche and PHP with mysql support

I've received reply from HP support. There is a bug in connection timeout processing code. They suggest to disable connection timeout (set "mysql.connect_timeout = -1" in php.ini) as a workaround.