General
cancel
Showing results for 
Search instead for 
Did you mean: 

BL890c i4 started with ERROR: "iocxgbe: The device at hardware path xxxxxxx failed initialization

 
Frequent Advisor

BL890c i4 started with ERROR: "iocxgbe: The device at hardware path xxxxxxx failed initialization

Hi ,

Happy new Year, wish you have a great journey in 2020 year.

I have a blade bl890c i4, with 2 vc flex-10/10D module. When the system booted, there are some error messages which need your help to diagnose the root cause:

iocxgbe: The device at hardware path 0/0/0/4/0/0/0 failed initialization (3885).
wsio_claim init failed isc=0xe00000099fc01c00 name=iocxgbe
iocxgbe: The device at hardware path 0/0/0/4/0/0/1 failed initialization (3885).
wsio_claim init failed isc=0xe00000099fc01c00 name=iocxgbe
fcoc3: Claiming Fibre Channel HBA port at hardware path 0/0/0/4/0/0/3
fcoc driver at 0/0/0/4/0/0/3 (/dev/fcoc3) : failed to initialize because mailbox interface is not ready.
Replacement of the HBA is recommended.

iocxgbe: The device at hardware path 2/0/0/3/0/0/0 failed initialization (3885).
DISASTER: instance number(ppa): 15

iocxgbe: The device at hardware path 2/0/0/3/0/0/1 failed initialization (3885).
DISASTER: instance number(ppa): 18
iocxgbe: The device at hardware path 2/0/0/3/0/0/5 failed initialization (3885).
DISASTER: instance number(ppa): 19
iocxgbe: The device at hardware path 2/0/0/3/0/0/7 failed initialization (3885).
iocxgbe20: INITIALIZING HP Dual Port CNA 10Gb BL8X0c i4 Embedded CNIC at hardware path 2/0/0/4/0/0/0
iocxgbe21: INITIALIZING HP Dual Port CNA 10Gb BL8X0c i4 Embedded CNIC at hardware path 2/0/0/4/0/0/1
DISASTER: instance number(ppa): 22
iocxgbe: The device at hardware path 3/0/0/3/0/0/0 failed initialization (3885).

DISASTER: instance number(ppa): 23
iocxgbe: The device at hardware path 3/0/0/3/0/0/1 failed initialization (3885).
iocxgbe_ilan_map_memspace: PCI Error Detected
iocxgbe: The device at hardware path 3/0/0/3/0/0/4 failed initialization (3215).
iocxgbe_ilan_init: PCI Error Detected
iocxgbe: The device at hardware path 3/0/0/3/0/0/0 failed initialization DISASTER: instance number(ppa): 25
iocxgbe: The device at hardware path 3/0/0/3/0/0/5 failed initialization (3885).
iocxgbe_ilan_map_memspace: PCI Error Detected
iocxgbe: The device at hardware path 3/0/0/3/0/0/6 failed initialization (3215).
iocxgbe_ilan_init: PCI Error Detected
DISASTER: instance number(ppa): 27
iocxgbe: The device at hardware path 3/0/0/3/0/0/7 failed initialization (3885).

 

Below is lanscan output:

# lanscan
Hardware Station        Crd Hdw   Net-Interface  NM  MAC       HP-DLPI DLPI
Path     Address        In# State NamePPA        ID  Type      Support Mjr#
0/0/0/3/0/0/0 0x645106B504CA 8   UP    lan8 snap8     1   ETHER     Yes     119
0/0/0/3/0/0/1 0x645106B504CE 9   UP    lan9 snap9     2   ETHER     Yes     119
0/0/0/4/0/0/0 0x645106B504D2 10  UP    lan10 snap10   3   ETHER     Yes     119
0/0/0/4/0/0/1 0x645106B504D6 11  UP    lan11 snap11   4   ETHER     Yes     119
1/0/0/3/0/0/0 0x645106B506B0 16  UP    lan16 snap16   5   ETHER     Yes     119
1/0/0/3/0/0/1 0x645106B506B4 17  UP    lan17 snap17   6   ETHER     Yes     119
1/0/0/4/0/0/0 0x645106B506B8 12  UP    lan12 snap12   7   ETHER     Yes     119
1/0/0/4/0/0/1 0x645106B506BC 13  UP    lan13 snap13   8   ETHER     Yes     119
2/0/0/4/0/0/0 0x645106B50B38 20  UP    lan20 snap20   13  ETHER     Yes     119
2/0/0/4/0/0/1 0x645106B50B3C 21  UP    lan21 snap21   14  ETHER     Yes     119
3/0/0/4/0/0/0 0x645106B507C6 28  UP    lan28 snap28   21  ETHER     Yes     119
3/0/0/4/0/0/1 0x645106B507CA 29  UP    lan29 snap29   22  ETHER     Yes     119

 

Thank you!

How time flies~~~
1 REPLY 1
Highlighted
HPE Pro

Re: BL890c i4 started with ERROR: "iocxgbe: The device at hardware path xxxxxxx failed initiali

Hi,

Wissh you a wonderful New year 2020

I dont know why server was rebooted, but it looks half of the LOM ports didnt initialize,

Are those still down? Any actions taken to recover?

Ideally we might need to reseat/efuse the system to recover the LOM ports from this scenario.

You can do this in two ways (after scheduling a downtime)

1.Power OFF and physically reseat the server (remove,wait for 2mins and insert).

2.Shutdown OS and Efuse from OA CLI -  (OA > reset server (bay number of monarch blade)

Unless there is a hardware issue, the LOM ports would recover.If stil fails after efuse and these LOm ports were working fine earlier, then please log a support ticket with HPE to investigate.

Thanks and Regards

I am a HPE Employee

Accept or Kudo