Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Bus error

Bus error

Hi, my DBA has following error when try
to export some tables:

$ exp brisi/brisi file=brisi.dmp log=brisi.log buffer=10000000 compress=n consistent=y tables=CALL_HISTORY:CALL_START_20011201 feedback=1000000

Export: Release 8.1.7.3.0 - Production on Pon Tra 15 09:53:39 2002

(c) Copyright 2000 Oracle Corporation. All rights reserved.


Connected to: Oracle8i Enterprise Edition Release 8.1.7.3.0 - 64bit Production
With the Partitioning option
JServer Release 8.1.7.3.0 - 64bit Production
Export done in EE8MSWIN1250 character set and EE8MSWIN1250 NCHAR character set

About to export specified tables via Conventional Path ...
. . exporting table CALL_HISTORY
. . exporting partition CALL_START_20011201
.......................................kgefec: fatal error 0
********** Internal heap ERROR 17113 addr=0x0 *********


******************************************************
HEAP DUMP heap name="" desc=0x0
extent sz=0x0 alt=0 het=0 rec=0 flg=0 opc=0
parent=0 owner=0 nex=0 xsz=0x0
Hla: 0

**** Recursive heap error: 17113 addr=0x0, ds=0

Bus error(coredump)

Does anybody know something about it?
Thanks in advance,
Hrvoje
7 REPLIES
Juan Manuel López
Valued Contributor

Re: Bus error

Hi,
I will try to help you.
I do not have idea about Oracle bbdd, so if you want if there was a I/O problem, then you have to see the /var/adm/syslog/syslog.log file or using dmesg command.
I hope this help you.

Juanma.
I would like to be lie on a beautiful beach spending my life doing nothing, so someboby has to make this job.

Re: Bus error

Thanks Juanma but it is not I/O problem. Host works fine, DB works fine.

Best regards,
Hrvoje
T G Manikandan
Honored Contributor

Re: Bus error

Hello,
What is the value for
MTS_MAX_DISPATCHERS
The error could be for teh small number value.

For a good description about MTS check the link below

http://www.dbatoolbox.com/WP2001/ops/mts_what.pdf

Re: Bus error

We are using dedicated server. MTS_MAX_DISPATCHERS is for MTS obviously.
Thanks anyway.

H.
harry d brown jr
Honored Contributor

Re: Bus error

Please read Bill Hassell's response:

http://bizforums.itrc.hp.com/cm/QuestionAnswer/0,,0x68cca2db8513d6118ff40090279cd0f9,00.html

On solaris the error "kgefec: fatal error 0" is caused by this:

EXPORT of DB on different platform leaks memory in the Export process. This memory leak can cause the export to fail with errors of the form: "kgefec: fatal error 0"


live free or die
harry
Live Free or Die
William Lara
Occasional Visitor

Re: Bus error

Where you able to solve this problem? I have an application administrator who got the same error today.

Thanks,
William
Dave's not here!
Ty Roberts
Frequent Advisor

Re: Bus error

We ran into this today.. and found this article on metalink.. we did as it said and it worked fine...

Cause ~~~~~~~ The operating system was not able to keep up with the Oracle Process. Fix ~~~~ Check system logs for errors. There may be an issue with physical memory. Try decreasing the buffer size in the export to prevent Oracle from sending so much data at once. In some environments, increasing the buffer will allow Oracle to hold more data in the buffer before sending it to the OS allowing the OS to catch up. Try running the export with DIRECT = TRUE. This will bypass the heap and heap and all possibility of this issue. If you are running the export from a client and the database is not the same wordsize, ie one is 32bit and the other is 64bit, you could be experiencing bug#2298968(unpublish), One-off is available for 8.1.7.4 and 9.0.1.3 in Metalink, fixed in 8.1.7.5, 9.0.1.4 and 9.2.0.1.