Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to Database Oracle Error -1033

Pine
Occasional Advisor

Cannot connect to Database Oracle Error -1033

Hello,

I have a Problem with my B132L-Workstation, running HP-UX 10.20 and Oracle 7.x. An application, which is based on the Oracle database won't start any more with the Error Message:
Cannot connect to Database Oracle Error -1033.

My first guess was, that the Harddisk is defective, or the Database is somehow corrupt. Against this theory speaks, that the System is normally booting, and the filesystem looks OK. (I checked with bdf).
Now what I could probably do, is to buy a new Harddisk, and install all the applications again, but I would loose all the data inside the Database.
Therefore before taking such a drastic measure, I would like to make sure, that the Harddisk is really defective.

- is there a way, to check the Harddisk? I heard of fsck. Can this be done safely on a mounted Filesystem?

- is there a way, to repair the Database?

Please help !!!
Pine
13 REPLIES
DCE
Honored Contributor

Re: Cannot connect to Database Oracle Error -1033

if there were no errors during startup, and the files and directories look ok, there probably is nothing wrong with your hard disk. The oracle 1033 error is related to the database being busy

ORA-01033: ORACLE initialization or shutdown in progress
Cause: An attempt was made to log on while Oracle is being started or shut down.
Action: Wait a few minutes. Then retry the operation.


Look at your database itself to correct the problem
A. Clay Stephenson
Acclaimed Contributor

Re: Cannot connect to Database Oracle Error -1033

Run oerr ora 1033.

You will be told that you are trying to to login while a shutdown or initialization is in progress. The action associated with this Oracle error is to wait a few minutes and try again

I doubt that you have a corrupt filesystem.
You may have to shutdown the database using svrmgrl. Try shutdown immediate first and then after being patient a shutdown abort. The shutdown abort is a non-friendly shutdown.

If it ain't broke, I can fix that.
Steven E. Protter
Exalted Contributor

Re: Cannot connect to Database Oracle Error -1033

Shalom Pine,

First, find out if the disk is deffective.

as root:

dmesg

Any warning about lbolt, bad disk?

mstm/cstm/xstm your choice. Test the disk with the excerize function.

If the disk fails the test, then yes you have probably lost the data. The tone of your message seems to apply that you do not in fact have a backup.

It could however be an oracle problem with the data itself. You need to see if the database can be recovered. Of course you can't call oracle, because the database is years past end of support.

The tests above can be safely done on a mounted filesystem.

Next:

umount the filesystem

run this:

fsck -F vxfs -o full -y

example
fsck -F vxfs -o full -y /dev/dsk/c1t1d0

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Victor Fridyev
Honored Contributor

Re: Cannot connect to Database Oracle Error -1033

Hi,
The reason for such an error may be a problem with the file system where files of databases are located.
Firs of all ensure that the database is up and running. For this login on the db server as user oracle and run
export ORACLE_SID=YOUR_SID
sqlplus system/manager
If this connect you to the db, check listener status by
lsnrctl stat
If this is OK, check Oracle environment on the client (TWO_TASK and tnsnames.ora file)

HTH
Entities are not to be multiplied beyond necessity - RTFM
Indira Aramandla
Honored Contributor

Re: Cannot connect to Database Oracle Error -1033

Hi Pine,

The error message could happen for numerous reasons.

Error: ORA 1033 : Oracle startup or shutdown in progress. One of the reasons would be that an attempt was made to log on to oracle database, while Oracle is being started up or shutdown.

Wait till the database is up as normal and then try your application. The order should be that when startup, the database should be started first and then the applications accessing the database. When shutdown, the applications accessing the databases should be shutdown first and then the database.
Check the database alert log for more messages and details. And also as Steven mentioned make sure the disk is fine and the file system is ok so as to eliminate them form the problem analysis.

Indira A
Never give up, Keep Trying
Yogeeraj_1
Honored Contributor

Re: Cannot connect to Database Oracle Error -1033

hi Pine,

above all make sure you have backups

Keep you old backup and do a full backup immediately. You may be required to do media recovery..

After that you can start troubleshooting.

Using various OS utilities or methods outlined in above replies, you can locate the exact problem.

hope this helps too!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Pine
Occasional Advisor

Re: Cannot connect to Database Oracle Error -1033

Hello all,

thanks for your replies!
It's unfortunately true, that the last backup is very old.

I checked my Alert.log:

*********************************************************
Starting ORACLE instance (normal)
LICENSE_MAX_SESSION = 0
LICENSE_SESSIONS_WARNING = 0
LICENSE_MAX_USERS = 0
Starting up ORACLE RDBMS Version: 7.3.2.3.0.
System parameters with non-default values:
processes = 50
shared_pool_size = 6000000
control_files = /home/opt/adaaaa/oracle/standard/cntrl1adaaaadb.ctl, /home/opt/adaaaa/oracle/standard/cntrl2adaaaadb.ctl
log_buffer = 163840
log_checkpoint_interval = 10000
db_files = 1021
rollback_segments = rs_1, rs_2, rs_3, rs_4, rs_5, rs_6, rs_7, rs_8, rs_9, rs_10, rs_11, rs_12
sequence_cache_hash_buckets= 10
remote_login_passwordfile= NONE
global_names = TRUE
mts_service = adaaaadb
mts_servers = 0
mts_max_servers = 0
mts_max_dispatchers = 0
audit_trail = NONE
sort_area_retained_size = 65536
sort_direct_writes = AUTO
db_name = adaaaadb
open_cursors = 150
background_dump_dest = /var/opt/adaaaa/log/oracle
user_dump_dest = /tmp
DBWR started
LGWR started
PMON started
RECO started
Wed Nov 30 15:30:31 2005
alter database mount exclusive
Wed Nov 30 15:30:31 2005
Successful mount of redo thread 1.
Wed Nov 30 15:30:31 2005
Completed: alter database mount exclusive
Wed Nov 30 15:30:31 2005
alter database open
Beginning crash recovery of 1 threads
Wed Nov 30 15:31:10 2005
Errors in file /tmp/ora_1269.trc:
ORA-00333: redo log read error block 3003 count 64
ORA-00312: online log 1 thread 1: '/home/opt/adaaaa/oracle/standard/log1adaaaadb.dbf'
ORA-07372: sfrfb: read error, unable to read requested block from database file.
HP-UX Error: 5: I/O error
Additional information: 3003
ORA-333 signalled during: alter database open...
**********************************************************

Usually I connect to the Database from my application. How can I connect to the db-server from a terminal window?

I tried the STM utilities, but these are not installed on my machine. Is it possible to install them on HP-UX 10.20. Is it freeware?

I tried to unmount the filesystem to do a fsck. But it would tell me for all logical volumes, that the device is busy.


Greetings
Pine
Lars Ebeling
Frequent Advisor

Re: Cannot connect to Database Oracle Error -1033

Is the there no Oracleprocesses running?

If not try to find a file named sgadef.dbf or something like taht.

Move that file to something else and try to start the database.

Regards
Lars
Lars Ebeling
Frequent Advisor

Re: Cannot connect to Database Oracle Error -1033

I didn't read the last post. If the databaseserver is stopped without shutting down the database first the my soluton could work.

But probably you have to make a recovery see:
http://www.orafaq.net/maillist/oracle-l/2001/12/04/0156.htm

regards
Lars
Pine
Occasional Advisor

Re: Cannot connect to Database Oracle Error -1033

Hello,

as Yogeeraj suggested, I am now trying to do a Backup.

As I have no experience, I made a test first on another machine (a B2000 also running HP-UX 10.20) with a similar application.

I used the following command with the following result:

# dd if=/dev/dsk/c2t6d0 of=/dev/rmt/0mn bs=1024k
I/O error
8306+0 records in
8305+1 records out
#

What is the error here?
Is this the correct command to do a backup?

Regards

Pine


Yogeeraj_1
Honored Contributor

Re: Cannot connect to Database Oracle Error -1033

hi,

at the oracle level, there are three ways that you can perform your backup.

1. Export (not recommended)
2. Online Oracle backup using RMAN (need a special setup)
3. Shutdown the database and backup the datafiles using OS utilities.


For option 1.
============
exp system/ file=exp.dmp full=y


For option 3.
=============
if you are not using raw device, you can just copy the datafiles. If you want to know which datafiles you are using, you can issue the command: "alter database using backup controlfile to trace;" at the sql prompt and view the log file generated in the udump directory.

if you need any further help, do let us know

kind regards
yogeeraj

PS. please dont forget to assign points so that you get more responses from others experts here. http://forums1.itrc.hp.com/service/forums/pageList.do?userId=BR883087&listType=unassigned&forumId=1

No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Ralf Seefeldt
Valued Contributor

Re: Cannot connect to Database Oracle Error -1033

Hello Pine,

please try to create a backup without the problem filesystem.

For /dev/dsk/c2t6d0:
- if you have lvols, try to back them up seperatedly
- try to repeat your dd command. Does it fail at the same block?
- try to copy only the first 8505 blocks with 'dd if=/dev/dsk/c2t6d0 of=/dev/rmt/0mn bs=1024k count=8305'
- try to find information about the size of the bad area with playing with the command
'dd if=/dev/dsk/c2t6d0 of=/dev/rmt/0mn bs=1024k skip=8306 count=10'
- try to copy the disk behind the bad block with 'dd if=/dev/dsk/c2t6d0 of=/dev/rmt/0mn bs=1024k skip=8305'
- if there is a bad spot on your disk, you can mark it as bad for the filesystem with "bad block allocation" but don't ask me how
- you may recreate the lvol and and place a seperate lvol in top of your bad block.
This will work fine if you realy have a bad area on your disk, do not want to buy a new one and the bad area does not grow in size.
- As far as I know - I am not a oracle-expert - you do not need .trc-files to start oracle. If so, you simply could delete that
file and try again. But get some information first, whether or not you realy do not need this file.

I hope, this is of some help for you.

Regards
Ralf
Simon Wickham_6
Regular Advisor

Re: Cannot connect to Database Oracle Error -1033

Hi,

First, Check your alert_SID.log file. You will get hints. You got the error ORA-01033 because you tried to login immediately after issuing shutdown command.

Try it once more.

Regards,
Simon