Showing results for 
Search instead for 
Did you mean: 

Forms3.0 with Oracle8i


Forms3.0 with Oracle8i

Our have an old application built with Forms30. This run against a database version 7.3.4.
We plan to upgrade our Database to Oracle 8i or 9i on IBM AIX 5L.
I have tested the connection with oracle 8i and 9i , but it doesn't work, I obtain:
"ORA-03113 end-of-file on communication channel"
The Forms30 and the oracle 9i are on the same server, but in different HOME.
I am using BEQ protocol adapters and TWO_TASK to connect the sqlforms30 to oracle9i.
I've references that this work fine.

anybody help me with this issue.


Patti Johnson
Respected Contributor

Re: Forms3.0 with Oracle8i


I have upgraded a 7.3.4 database to 8i and was still able to access forms3.0 and forms 4.5.
When you login as the user accessing forms are all your environment variables still pointing to the 7.3.4 Oracle Home.
Also can you login to sqlplus from the forms user account (using the TWO_TASK setting).

You may want to setup the TCP protocol instead of BEQ when going from Forms 3.0 to Oracle 8i.


Honored Contributor

Re: Forms3.0 with Oracle8i


we have been using form30 with oracle 8i and tested ok with oracle9i.

however, with oracle 10g, it does not work at all!

these configuration is indeed not supported by Oracle since long ago.

good luck
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)

Re: Forms3.0 with Oracle8i


I also tried with TCP protocol, but still the problem persist.
I've two HOME, one for the Oracle9i and other for the forms30. The forms30 has the environment variable of the Oracle 7.3.

I believe that problem is the characterset of my database Oracle9i.

The runtime forms work fine.I tested some of our forms built in forms30 also work fine, but the sqlforms has problem and shows the ORA-03113.


Fekete Josef
Occasional Visitor

Re: Forms3.0 with Oracle8i


We also had this problem. We used the WE8ISO8859P15 Character set in the 9i database. Had to change it to WE8ISO8859P1:

startup mount

alter system enable restricted session;

alter system set job_queue_processes=0;

alter system set aq_tm_processes=0;

alter database open;

alter database CHARACTER set internal_use WE8ISO8859P1;

shutdown immediate


Best regards