cancel
Showing results for 
Search instead for 
Did you mean: 

HPUX does not boot

SOLVED
Go to solution
JUP
Regular Advisor

HPUX does not boot

Hi

Our HP Itanium rx2660 11.31 system has been running without any issue. It was shutdown and now it won't boot. The following error appears after the Autoboot message:

System Memory = 2027 MB
Could not allocate enough memory for kernel’s data segment

The system then remains at the HPUX> boot prompt.

I tried to boot of an alternate kernel so at the HPUX> prompt I typed in:

boot backup/vmunix

This made no difference, the system replies with the same message above. I can not boot in single user mode either, same error.

I can list the kernel files from the HPUX> prompt, it shows the date stamp of the vmunix files (current and backup directory) are both from 2008 so does not seem to be a change in the kernel that caused this issue. It was however mentioned to me by a colleague (who is not contactable) that a kernel change may have taken place during past few weeks re. memory, however the dates on the vmunix file does not indicate that. Is it possible other files are modified and not vmunix when a kernel change is made ?

If anyone can assist, it would be greatly appreciated.

Thanks in advance
Paul
10 REPLIES
Torsten.
Acclaimed Contributor
Solution

Re: HPUX does not boot

From EFI prompt please run "info" all and post.


EFI> info all

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Matt Palmer_2
Respected Contributor

Re: HPUX does not boot

Have u watched the init process from the MP Console, and checked that there are no hardware issues, board problems,etc.

regards

Matt
JUP
Regular Advisor

Re: HPUX does not boot

Thanks for your prompt reply.
I have now left the office (its past 11:00pm here in Aust) and will not be able to post a response till the morning.
Torsten.
Acclaimed Contributor

Re: HPUX does not boot

System Memory = 2027 MB


This could be a little less - maybe you have some failed DIMMs.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
JUP
Regular Advisor

Re: HPUX does not boot

Thanks Torsten for your help.

Here is the "info all" output:

fs0:\> info all

SYSTEM INFORMATION

Date/Time: Sep 29, 2010 21:51:04 (20:10:09:29:21:51:04)
Manufacturer: hp
Product Name: server rx2660
Product Number: AB419A
Serial Number: SGH48120M7
UUID: 78D17D6C-132F-11DD-9763-AE555C931BD4
System Bus Frequency: 266 MHz

PROCESSOR MODULE INFORMATION

# of L3 L4 Family/
CPU Logical Cache Cache Model Processor
Module CPUs Speed Size Size (hex.) Rev State
------ ------- -------- ------ ------ ------- --- ------------
0 1 1.6 GHz 6 MB None 20/00 C2 Active


MEMORY INFORMATION

---- DIMM A ----- ---- DIMM B -----
DIMM Current DIMM Current
--- ------ ---------- ------ ----------
0 1024MB Active 1024MB Active
1 ---- ----
2 ---- ----
3 ---- ----

Active Memory : 2048 MB
Installed Memory : 2048 MB


I/O INFORMATION


BOOTABLE DEVICES

Order Media Type Path
----- ---------- ---------------------------------------
1 HARDDRIVE Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C5000920501
1,Lun0)/HD(Part1,Sig435E3D68-4FA3-11DD-8000-D6217B60E588)
2 HARDDRIVE Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C5000920501
1,Lun0)/HD(Part3,Sig435E3DC2-4FA3-11DD-8000-D6217B60E588)




Seg Bus Dev Fnc Vendor Device Slot
# # # # ID ID # Path
--- --- --- --- ------ ------ --- -----------
00 00 01 00 0x103C 0x1303 XX Acpi(HWP0002,PNP0A03,0)/Pci(1|0)
00 00 01 01 0x103C 0x1302 XX Acpi(HWP0002,PNP0A03,0)/Pci(1|1)
00 00 01 02 0x103C 0x1048 XX Acpi(HWP0002,PNP0A03,0)/Pci(1|2)
00 00 02 00 0x1033 0x0035 XX Acpi(HWP0002,PNP0A03,0)/Pci(2|0)
00 00 02 01 0x1033 0x0035 XX Acpi(HWP0002,PNP0A03,0)/Pci(2|1)
00 00 02 02 0x1033 0x00E0 XX Acpi(HWP0002,PNP0A03,0)/Pci(2|2)
00 00 03 00 0x1002 0x515E XX Acpi(HWP0002,PNP0A03,0)/Pci(3|0)
00 01 01 00 0x1000 0x0054 XX Acpi(HWP0002,PNP0A03,200)/Pci(1|0)
00 01 02 00 0x14E4 0x1648 XX Acpi(HWP0002,PNP0A03,200)/Pci(2|0)
00 01 02 01 0x14E4 0x1648 XX Acpi(HWP0002,PNP0A03,200)/Pci(2|1)
00 02 01 00 0x114F 0x0058 03 Acpi(HWP0002,PNP0A03,300)/Pci(1|0)
00 04 01 00 0x1000 0x0030 01 Acpi(HWP0002,PNP0A03,700)/Pci(1|0)
00 04 01 01 0x1000 0x0030 01 Acpi(HWP0002,PNP0A03,700)/Pci(1|1)



Fast initialization: Enabled
System Wake-On-LAN: Enabled

BOOT INFORMATION

Monarch CPU:

Current Preferred
Monarch Monarch
CPU CPU
Module/ Module/
Logical Logical Warnings
------- --------- --------
0/0 0/0

AutoBoot: ON - Timeout is : 10 sec

Boottest:

BOOTTEST Settings Default Variable

Selftest Setting
--------- --------------
early_cpu Run this test
late_cpu Run this test
platform Run this test
chipset Run this test
io_hw Run this test
mem_init Run this test
mem_test Run this test

LAN Address Information:

LAN Address Path
----------------- ----------------------------------------
*Mac(001CC4FBFB93) Acpi(HWP0002,PNP0A03,200)/Pci(2|0)/Mac(001CC4FBFB93)
Mac(001CC4FBFB92) Acpi(HWP0002,PNP0A03,200)/Pci(2|1)/Mac(001CC4FBFB92)


FIRMWARE INFORMATION


*System Firmware A Revision: 3.01 [4739]
PAL_A: 7.31/7.46
PAL_B: 9.08
EFI Spec: 2.00
EFI Intel Drop: 14.62
EFI Build: 6.20
SAL Spec: 3.20
SAL_A: 2.00
SAL_B: 3.01
POSSE: 0.23
ACPI: 7.00
SMBIOS: 2.3.2a
System Firmware B Revision: 3.01 [4739]
BMC Revision: 5.21
IPMI: 1.00
Management Processor Revision: F.02.17
Updatable EFI Drivers:
Floating-Point Software Assistance Handler: 00000118
Broadcom Gigabit Ethernet Driver: 00090404
SCSI Bus Driver: 00000031
SCSI Disk Driver: 00000020
SCSI Tape Driver: 00000030
Usb Ohci Driver: 00000040
USB Bus Driver: 00000020
USB Bot Mass Storage Driver: 00000020
Generic USB Mass Storage Driver: 00000020

* Indicates active system firmware image

WARNING AND STOP BOOT INFORMATION


CHIP REVISION INFORMATION

Chip Logical Device Chip
Type ID ID Revision
------------------- ------- ------ --------
Memory Controller 0 4032 0020
Root Bridge 0 4030 0020
Host Bridge 0000 122e 0032
Host Bridge 0002 122e 0032
Host Bridge 0003 12ee 0011
Host Bridge 0006 12ee 0011
Host Bridge 0007 12ee 0011
Other Bridge 0 0 0030
Other Bridge 0 0 5007
Baseboard MC 0 0 0521


SYSTEM SECURITY CONFIGURATION
Trusted Boot: Not Supported
TPM: Not Present


fs0:\>
Patrick Wallek
Honored Contributor

Re: HPUX does not boot

Between:

>>System Memory = 2027 MB
>>Could not allocate enough memory for kernelâ s data segment

and this:

>>MEMORY INFORMATION
>>---- DIMM A ----- ---- DIMM B -----
>>DIMM Current DIMM Current
>>--- ------ ---------- ------ ----------
>>0 1024MB Active 1024MB Active
>>1 ---- ----
>>2 ---- ----
>>3 ---- ----

I'd say you have some sort of RAM issue or system board issue. I don't remember how much RAM 11.31 needs to but, but evidently it needs more than 2027 MB.

I would open a hardware support call on this server ASAP.
JUP
Regular Advisor

Re: HPUX does not boot

Hi Matt,

Do you mean the following boot up messages? If not, can you please let me know the instructions?

***********************************************************
* ROM Version : 03.01
* ROM Date : 09/26/2007
* BMC Version : 05.21
***********************************************************
0 0 0x0015B2 0x0000000014567854 boot time event
1 0 0x0000A4 0x0000000000000000 start memory configuration
2 0 0x001CBB 0x0000000000000000 System set to insecure mode
0 0 0x0015B2 0x0000000017235102 boot time event
1 0 0x000014 0x0000000000000000 CPU0 starting cell relocation
1 0 0x000009 0x0000000000000000 CPU0 launch EFI

EFI version 2.00 [14.62]
EFI64 Running on Intel(R) Itanium Processor Family
UEFI 2.0 IPF server rx2660 6.20 [Fri Feb 23 17:21:28 2007] firmware by HP

Copyright (c) 2000-2006 Broadcom Corporation
Broadcom NetXtreme Gigabit Ethernet EFI driver v9.4.4

Loading 'SysROM:Floating-Point Software Assistance Handler'...
-- 'SysROM:Floating-Point Software Assistance Handler' returned Success
Loading 'SysROM:SCSI Bus Driver'...
-- 'SysROM:SCSI Bus Driver' returned Success
Loading 'SysROM:SCSI Disk Driver'...
-- 'SysROM:SCSI Disk Driver' returned Success
Loading 'SysROM:SCSI Tape Driver'...
-- 'SysROM:SCSI Tape Driver' returned Success
Loading device drivers

EFI Boot Manager ver 2.00 [14.62] Firmware ver 3.01 [4739]

Please select a boot option

HP-UX Primary Boot: 0/1/1/0.0x5000c50009205011.0x0
iLO Virtual Media
Core LAN A
Core LAN B
EFI Shell [Built-in]
Internal Bootable DVD
Boot Option Maintenance Menu
System Configuration


Use ^ and v to change option(s). Use Enter to select an option
Loading.: HP-UX Primary Boot: 0/1/1/0.0x5000c50009205011.0x0
Starting: HP-UX Primary Boot: 0/1/1/0.0x5000c50009205011.0x0

(C) Copyright 1999-2006 Hewlett-Packard Development Company, L.P.
All rights reserved

HP-UX Boot Loader for IPF -- Revision 2.035

Press Any Key to interrupt Autoboot
\EFI\HPUX\AUTO ==> boot vmunix
Seconds left till autoboot - 0
AUTOBOOTING...> System Memory = 2027 MB
Could not allocate enough memory for kernel's data segment.

loading failed

HPUX>

Thanks,
JUP
JUP
Regular Advisor

Re: HPUX does not boot

Thanks Patrick. We have logged a support call to HP.
JUP
Regular Advisor

Re: HPUX does not boot

More information, the following error messages on the Event Log:

# Location|Alert| Encoded Field | Data Field | Keyword / Timestamp
-------------------------------------------------------------------------------
96 SFW *5 0xC14CA2CA84020910 FF3F4070000F0300 SYSTEM_FIRMWARE_ERROR
29 Sep 2010 05:11:32
97 SFW 0 *5 0xA08000D800E00920 0000000000000000 MEM_PDT_TABLE_FULL
29 Sep 2010 05:11:32

JUP
Regular Advisor

Re: HPUX does not boot

Our system only has 2G RAM. However one of the DIMMs was faulty.

After replaced the DIMMs pair, the system now boots up without any issues.

Thank you all for your helps.