cancel
Showing results for 
Search instead for 
Did you mean: 

Kickstart build issue

Andrew medhurst1
Frequent Advisor

Kickstart build issue

Guys i have 10 blade servers that need building like yesterday.
i an trying to build using a kickstart file and setting up the virtual cd and usb/floppy.
i cannot get the kickstart to read i have tried using HD and floppy and get the same issue " unable to download kickstart file"
i am not a hp blade expert and no matter what i try i cannot seem to get the blade to read the kickstart.
Am i being stupid or something, i have even tried a old proven kickstart in an attempt to check validity of the newly created files.
i still get the same problem.
HELP this is now a bit issue i do not want to have to build manually 10 servers that i need the same.
regards
Andrew
5 REPLIES
Joseph L. Casale
Regular Advisor

Re: Kickstart build issue

what distro, and what is your boot syntax?

Drop into a shell and attempt to enumerate the device your storing the ks file on, if you're doing this through ilo iirc it attatches virtual devs as usb devices so your syntax is possibly wrong.

Do you have a web server handy? That's the method I use...

jlc
RColliard
Occasional Visitor

Re: Kickstart build issue

Hi Andrew,

Personally what I am doing, is using UltraISO to edit .ISO file to put a ks.cfg file in the root of the DVD image. With previous version 9.3.2.2656 (the latest 9.3.3.2685 has a bug) you are able to save only the difference to the ISO file which is really fast.

Then I mount the .iso image with iLO, and launch the install with "linux ks=cdrom:/ks.cfg" and that's it.

I know there should be other ways to do it through the network (i.e. pxe boot and ks.cfg on the LAN) but it is the easiest way to my opinion.

Regards,
Raphael
Colin Topliss
Esteemed Contributor

Re: Kickstart build issue

Its because the virtual CDROM isn't the same as a physical CDROM.

Try

linux ks=hd:scd0:/ks.cfg

Regards

Colin.
Andrew medhurst1
Frequent Advisor

Re: Kickstart build issue

found the issue seemed to be the dammed stupid ilo even raised a call to hp about this but still received no resolution.
i found one of the serial cables that came with the blade and by pluging in directly to the blade in question hey presto it works as expected.
so all built 6 mins per blade so i think that this is the way to go.
many thanks for the reply's.
Andrew
Andrew medhurst1
Frequent Advisor

Re: Kickstart build issue

updated