Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Largefile option problem

SOLVED
Go to solution
Balakumar M
Frequent Advisor

Largefile option problem

Hi Everybody,
I am encountring problem with largefile option,
I have a mount point /mnt about 36GB mounted without Largefile option. we have backuped the database to a single file data.arc ( 2147483136 KB) after that we are not able to write to the file. so what i did is umounted the mount point and did the following things,
1) fsadm -F vxfs -o largefiles /dev/vg02/rback1
2) fsadm -F vxfs /dev/vg02/rback1
largefiles
Seem's ok.
3) edited the fstab and added
/dev/vg02/back1 /mnt vxfs largefiles,delaylog 0 2
4) mount -a
No error's found, everything is fine.

We used the same file to backup database, but file doesn't grow, I have copied the file to another file and tried, same problem.

My question is
Is that possible to use the same file?
any solution?

-Bala
Life is a continues learning process
4 REPLIES
Steven Sim Kok Leong
Honored Contributor

Re: Largefile option problem

Hi,

What backup software are you using? Some software like the default tar utility which comes with HP-UX only supports 2 GB maximum file size, regardless of whether your filesystem has been enabled for largefiles support.

Hope this helps. Regards.

Steven Sim Kok Leong
Email: steven@beepz.com. Homepage: https://www.beepz.com
Hasell Blad
Advisor

Re: Largefile option problem

Hi,
your procedure was good to me,
but there was sam problem.

check the following.
fsck -F vxfs /dev/vg02/rback1

if largefiles appears, you
can use the sam file.
Hudson
Steve Steel
Honored Contributor
Solution

Re: Largefile option problem

Hi

MAYBE
Hi

ulimit is wrong

I would guess that the "ulimit -a" command indicates that file (blocks)
are set to the default:
check # ulimit -a
...
NOTE: Use the posix shell to reset the ulimit() command. (See the man page for the ulimit command and its options.)

Default filesize: 512byte * 4194303 = 2GB limit
So # ulimit -Hf unlimited
# ulimit -Sf unlimited
Check to make sure file (blocks) are unlimited:

# ulimit -a
Change in /etc/profile, if needed,

Steve Steel
If you want truly to understand something, try to change it. (Kurt Lewin)
Animesh Chakraborty
Honored Contributor

Re: Largefile option problem

Hi,
Use the prealloc command. eg. to create a 2.5Gb file to test out if largefiles is on; prealloc testfile 2500000000

If prealloc returns the error; file too large you know you havent got largefiles on.
Did you take a backup?