Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Linux LVM online resize error - resize2fs

Mydheen
Occasional Contributor

Linux LVM online resize error - resize2fs

Hi,

 

my server is linux RHEL 6.6 (patch version 2.6.32-358.el6.x86_64). i have tried to increase a filesystem online using resize2fs.

 

the mount point was 1TB already, and i need to increase 2TB more. so the final size would be 3TB.

i had 1 TB size (2 disks) lun, and have extended the VG first using the 2 luns. so i had 2 TB ( and some extra 300GB) free in the VG.

 

lvextend -l +100%PVS /dev/arch-VG/arch001-vol /dev/emcpowerag1

lvextend -l +100%PVS /dev/arch-VG/arch001-vol /dev/emcpoweraf1

 

# lvs | grep -i arch001
arch001-vol arch-VG -wi-ao---- 2.93t

 

above was the output once i did lvextend. then when i tried to do resize2fs, it should increase the new 2TB. but i got the below error.

 

# resize2fs /dev/arch-VG/arch001-vol
resize2fs 1.41.12 (17-May-2010)
Filesystem at /dev/arch-VG/arch001-vol is mounted on /arch01; on-line resizing required
old desc_blocks = 63, new_desc_blocks = 188
Performing an on-line resize of /dev/arch-VG/arch001-vol to 786423808 (4k) blocks.
resize2fs: Operation not permitted While trying to add group #8064
[root@BEC19-ENC1-7 dev]#

 

hence requesting your advice on how to go about this. please let me know if any more details required.

 

Regards,

mydheen

1 REPLY
Mydheen
Occasional Contributor

Re: Linux LVM online resize error - resize2fs

Just to add to the above post,

 

then when i verified what might have gone wrong. i see that one of the disk showing as "unallocatable". please advice.

i tried to change the allocatability. but no luck, may be as this disk is part of vg, i would not be able to perform this pvchange.

 

# pvdisplay /dev/emcpowerah1
"/dev/emcpowerah1" is a new physical volume of "1000.00 GiB"
--- NEW Physical volume ---
PV Name /dev/emcpowerah1
VG Name
PV Size 1000.00 GiB
Allocatable NO
PE Size 0
Total PE 0
Free PE 0
Allocated PE 0
PV UUID GWYuI7-LY4x-fspx-bUG2-4m8E-Q6rJ-TAYFfe

 

 

# pvchange -x y /dev/emcpowerah1
Allocatability not supported by orphan lvm2 format PV /dev/emcpowerah1
0 physical volumes changed / 1 physical volume not changed