Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

Oracle 8.1.7 Error

Go to solution

Oracle 8.1.7 Error

Hi everyone,

We are running HPUX 11.0 with the June 2001 patches installed on L-Class machines and getting this error when running svrmgrl

gfbtstn1(root/?): svrmgrl
Oracle Server Manager Release - Production
Copyright (c) 1997, 1999, Oracle Corporation. All Rights Reserved.
ORA-03113: end-of-file on communication channel

We have done a trace and its trying to do a
gettimeofday call

Please help!!
Can you imagine life without beer?
Alexander M. Ermes
Honored Contributor

Re: Oracle 8.1.7 Error

Hi there.
Try this URL :,1150,0x8bb853921f1ad5118fef0090279cd0f9,00.html

Alexander M. Ermes

.. and all these memories are going to vanish like tears in the rain! final words from Rutger Hauer in "Blade Runner"
Volker Borowski
Honored Contributor

Re: Oracle 8.1.7 Error

May be some libs have been updated by the patches and a relink of oracle is required ?


Re: Oracle 8.1.7 Error

Hi Volker,

This a new installation and the operating system and patches were installed before oracle

Can you imagine life without beer?
T G Manikandan
Honored Contributor

Re: Oracle 8.1.7 Error

Please check your kernel parameters.
semmns parameters.
tune the parameters accordingly.
G Manikandan
Honored Contributor

Re: Oracle 8.1.7 Error

if patch PHSS_22478 doesn't exist, svrmgrl gives the communication problem. if your system already has this patch then check for shared memory and semaphores parameters has been set to Oracle values.

never give up
T G Manikandan
Honored Contributor

Re: Oracle 8.1.7 Error

How to fix it

1. Oracle Server Errors
If the failure occurs after a connection is established, a likely cause is a database server error. For example in my personal experiences all versions of Oracle server before 8.1.6 are pretty unstable under Windows NT 4.0 with Service Pack 6.0 and frequent internal errors cause the server to discontinue its operation. In such cases one should see the alert log and will usually have to refer to Oracle Support. In the case mentioned above you should downgrade to Service Pack 5.

2. Net8 Server (Listener) Errors
This is when the listener fails to respond to Net8 client. The causes for such a failure are numerous. Lack of memory on the server machine where the listener resides, or problems with the host operating system can cause the listener to fail. To make sure that the listener is working correctly one may use the Listener Control Utility (LSNRCTL.) More about Net8 server here One may also restart listener using the host operating system facilities LSNRCTL or to recover from temporary errors.

3. The Network Connection Failure
This is when the network connection through the network protocol is no longer available. For example when using the TCP, a TCP/IP route must be available between the client machine and the server. This may be tested using the ping utility. There are also situations when a specified protocol is disabled for a machine, say when conflicting IP addresses occur or a router device or software fails. In such cases it may be possible to reach the listener through other protocols like Named Pipes. In such cases you should call for the network administrator to fix the problem or you can change the protocol in use. To change the protocol, change the protocol entry and the parameters for the connection string in use, in TNSNAMES.ORA or for the method in use (Oracle Names or external naming services.) Say in the TNSNAMES.ORA one may start using conn_nmp (Named Pipes) after conn_tcp fails. More info on this here. However bear in mind that in this case the listener must support NMP too for a connection to be established. To have listener support a new protocol one may use Net8 Assistant, LSNRCTL or edit listener.ora manually and restart the listener using the host operating system facilities.

4. Defunct processes are still running
Check to see that there are no defunct processes running:
ps -ef | grep oracle
Since you are doing a startup, you can kill those defunct processed from the prompt (kill -12 ...) and then try to a startup

Re: Oracle 8.1.7 Error

hi all,

problem solved.

Bumped shmmax up and bingo it worked
thanks for your help!

Can you imagine life without beer?