Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Showing results for 
Search instead for 
Did you mean: 

Oracle Error messages

Oracle Error messages

When I installing Oracle 8i for HP-UX 11.0 unto 94%,The installer show me two error messages:

The message 1#
Error in invoking target ioracle of makefile /u01/oracle/OraHome1/rdbms/lib/

The message 2#
Error in invoking target ioracle of makefile /u01/oracle/OraHome1/rdbms/lib/

All Environment set done for Oracle user's .profile.

I would appreciate some advice from you!
I believe i can fly!
Haitham Hamad
Regular Advisor

Re: Oracle Error messages

I normally re-install again whenever I get relinking problems. Make sure that your /temp is > 150 MB. Their recommended 75MB is just not enough. I tried once using $TEMPDIR in the .profile instead of /temp but it didn't work so I went back to /temp and increased it to 256MB. Also make sure you have enough space on oracle's installation directory/filesystem.

Hope this helps

Re: Oracle Error messages

Thank you for your help!

You are right!My /tmp just only 40mb free space.Too small space.

Thank you!
Jackie Xu
I believe i can fly!
Respected Contributor

Re: Oracle Error messages

I would give him 10 points for his answer !!!
Volker Borowski
Honored Contributor

Re: Oracle Error messages

Hi Jackie,

I had this recently within a patch from to !
After this failed, we tried to reinstall -> Did not work either. Same link error. Finally, we restored the backup of the executables (they work OK).

We did not manage to get it to work. After this, it turned out, that the executables of oracle have been copied (not installed) from another box. We still did not figure out what was missing, but it must have been something from the installation requirements (Patches to linker, or some libs). I suspect 32-bit vs. 64 bit mismatch here, esp. as somebody did not install, but simply copied the execs.

We are still tracking on this.

On the other hand, I had several installations on diffrent plattforms (HP-UX, AIX), where it failed because of insufficiant /tmp space, but there was always a clear message indicating this, a popup to be confirmed after fix, and a successfull retry after extension of /tmp.

So I am very interested, if this /tmp thing did work for you (esp. as you did not had an error message).

Occasional Visitor

Re: Oracle Error messages

Hello, I had this problem and the solution is that you have to modify the kernel parameter maxdsiz to 256000000.

This is O.K to install Oracle 8i or 8.1.7.