Showing results for 
Search instead for 
Did you mean: 

Oracle dbconsole

Charles Egbon
Regular Advisor

Oracle dbconsole

Hi Guys,

I have Oracle 10gR1 on HPUX 11iR1. I tried to start the web console by running "emctl start dbconsole". I got the following error:
/home/oracle (oracle) #emctl start dbconsole
OC4J Configuration issue. /home/oracle/oc4j/j2ee/OC4J_DBConsole_S_
not found.
I checked the directory and OC4J_DBConsole_S_ does not exit.
What could be wrong?
Steven E. Protter
Exalted Contributor

Re: Oracle dbconsole


You have found the problem.

The emctl script is configured to work in a directory that does not exist.

Go back and follow the correct oracle installation procedure and report any problems back to this thread or to oracle.

Do not gloss over an problems with the install procedure, fix them. Skipping steps in Oracle setup is a recipe for failure.

Steven E Protter
Owner of ISN Corporation
Charles Egbon
Regular Advisor

Re: Oracle dbconsole

Waoo. reinstalling the oracle is not a workable option for me. I run 24/7 business. Can hardly accept downtime. Is there any other clew?

Re: Oracle dbconsole


I think you "copied" the db from an another host, right? If so you are to generate emctl support for the db on this host. Suppose you have configured the tnsnames.ora and listener.ora files in right way. You can use the following commang
> emca -repos recreate
and than use dbca to "import" the db into the host environment.
Super Advisor

Re: Oracle dbconsole

Check what the $ORACLE_HOSTNAME is...
Set it to make sure it is what your oracle sid is in your: $ORACLE_HOME/DB1/.
This is where all your OEM configuration is.
Eric Antunes
Honored Contributor

Re: Oracle dbconsole

Hi Charles,

Try this as the database owner user (oracle?):

oemapp console

Best Regards,

Eric Antunes

Each and every day is a good day to learn.