Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

SCSI problem with sym53c8xx driver

SCSI problem with sym53c8xx driver

Hello,

I have a HP Proliant DL380 server with an onboard cciss scsi controller. This one is used for 4 harddisks. An additional adapter is in the server for a StorageTek L80 Robotic changer. This is a Symbios adapter.

The OS is RedHat AS 2.1.

In the modules.conf:

alias scsi_hostadapter cciss
alias scsi_hostadapter1 sym53c8xx

The problem is that the sym53c8xx driver is not loaded at boot time. When I do a manual insmod sym53c8xx the robotic changer is found.
Why does Linux not load the driver? It does load the cciss driver.

Regards,

Leon
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: SCSI problem with sym53c8xx driver

Are you sure that you have the right driver?

I ask because in a scsi install with a different OS that is the driver I got for a scsi card that was detected but the OS didn't know the driver for it.

The system blew up spectacularly when I actaully tried bringing up the scsi card after the fact.

Probably not helpful, but I thought I'd let you know anyway.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Caesar_3
Esteemed Contributor

Re: SCSI problem with sym53c8xx driver

Hello!

You must check if in the boot process
the module is tried to insert into.
Also the linux system work this way that
if no use for module than he not loaded.

Caesar
Stuart Browne
Honored Contributor

Re: SCSI problem with sym53c8xx driver

I've found that a number of controllers using Symbios 53c8xx controllers don't get picked up by the 'sym*' driver, but by the 'ncr*' driver. Is this module loaded?

Is the 'st' module getting inserted at bootup?

In any case, just throw a 'modprobe' in your rc.local routines.. it'll force the loading of the module upon boot-up..
One long-haired git at your service...
Christoph Jahn_1
Occasional Visitor

Re: SCSI problem with sym53c8xx driver

Hi Leon,

Did you check whether the driver is listed in /etc/modules.conf for being loaded during start-up?

As the others wrote, it is vitally important not to get confused with the numerous NCR/Symbios drivers floating around. So does the driver work properly when you do the insmod manually?

Regards,
Christoph
Jacob Good
Occasional Visitor

Re: SCSI problem with sym53c8xx driver

try typing

"dmesg | grep sym"

dmesg prints out the kernel messages.. then it will grep for the sym driver and see if it loaded correctly.. you can also just pipe it into more or less to read the rest of the messages

"dmesg | more" or "dmesg | less"

From there you can figure out if it got loaded at runtime or not!

Jake
without RAM I am nothing
I_M
Honored Contributor

Re: SCSI problem with sym53c8xx driver

Hi,

Currently, your system failed to install scsi driver....just try if you can insert the scsi driver form command line.

# lsmod (See if sym53c8xx is in kernel)
# insmod sym53c8xx
# lsmod (confirm the driver is in or not)

If you success to load the driver, what you need is configure initrd.
You just write "alias scsi_hostadapter1 sym53c8xx" into /etc/modules.conf. This is not enough.

# /sbin/mkinitrd /boot/initrd-kernel-version.img your-kernel-version

your-kernel-version = "uname -r"
After this command, edit /etc/lilo.conf or /etc/grub.conf. If you are using lilo, /sbin/lilo is needed after you modify it.

If you failed to load the sym53c8xx manually, I guess something wrong with your system.
Say, system failed to detect the scsi card.
see # cat /proc/pci or lspci -vt to see if your kernel can detect the scsi card.

good luck



Re: SCSI problem with sym53c8xx driver

Hello,

Sorry for the late response, I did not recieve mail notifications.

The driver does not load at boot time. No attempts either. It is the correct driver, because a manual insmod does work fine. And the scsi device is working fine as well after that.

I'm going to try the solution of Masanari Iida and let the results know.

Regards,

Leon