General
cancel
Showing results for 
Search instead for 
Did you mean: 

SLES 11 / PSP 8.60 - hpsum input file does not work

Brunold Rainer
Occasional Contributor

SLES 11 / PSP 8.60 - hpsum input file does not work

Hello,

I'm currently trying to automate the installation of the PSP 8.60 on our SLES 11 systems by using a input file and have the problem that at least the different groups do not get configured in the smh config file.

I use the following command to initiate the install:
# ./hpsum -inputfile hpsum.in -s

and use the following input file:
#SILENT = YES
DOWNGRADE=NO
REBOOTALLOWED=NO
SKIPTARGET=NO
LOGFILENAME=/images/hppsp.log
HPVCAVCRMSERVER=HPVCA.DOMAIN.COM
HPVCAVCRMLOGINID=hpvcauser
HPVCAVCRMLOGINPASSWD=hpvcapwd
FORCE-OVERWRITE=YES
ADMIN-GROUP=PSPADMIN
OPERATOR-GROUP=PSPOPER
USER-GROUP=PSPUSER
ANONYMOUS-ACCESS=NO
[TARGETS]
HOST=localhost
[END]

I can see in the debug logs that the parameters from the input file get read, but when I check the /opt/hp/hpsmh/conf/smhpd.xml afterwards the groups are not set.

Any ideas where this problems comes from ?

Thanks,
Rainer
1 REPLY
Brunold Rainer
Occasional Contributor

Re: SLES 11 / PSP 8.60 - hpsum input file does not work

I spent now a little bit time on this and there seems to be something really broken with this.

I start hpsum with the GUI and configure all settings. Then I save the file and try to use it as a input file for the next try. I do not try the silent install this time, I want to see if the parameters are accepted, so I run

# hpmsum -inputfile HDUCONFIG-ORI.cfg

It reports error in the file until I recode it into a utf-8 file and uncomment the first line in the file. Then hpsum starts but I do not have the configurations set when I verify that.

SO when they are not taken here, it might be the same problem as when I run it in silent mode.

Any ideas ?

Rainer