Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Samba 3.0 with Active Directory net ads join problem

Jonas Back_2
Super Advisor

Samba 3.0 with Active Directory net ads join problem

We have a AD-domain using Windows 2003 servers. We want to join our RH ES3 Samba (3.0.0-14.3E that was shipped with ES3) to our AD-domain. We get no error when running kinit but when trying to join the domain with "net ads join -U username" we don't get any successful nor errormessage. If you look at the log at the DC we get the following:
-----CUT-----
Pre-authentication failed:
User Name: username
User ID: PPM\username
Service Name: krbtgt/DOMAIN.COM
Pre-Authentication Type: 0x0
Failure Code: 0x19
Client Address: 192.168.xx.xx
-----CUT-----
The user we're using is a Domain Admin. We've followed most of the guides on the net and it should simply work with net ads join. We have also tried pre-creating a computer account in the AD domain for the server. In the configfiles below we also tried specifying a password server = in and workgroup = DOMAIN in smb.conf. There's no info in the krb5-logs.

Any ideas?


/etc/krb5.conf
[logging]
default = FILE:/var/log/krb5libs.log
kdc = FILE:/var/log/krb5kdc.log
admin_server = FILE:/var/log/kadmind.log
[libdefaults]
ticket_lifetime = 24000
default_realm = DOMAIN.COM
dns_lookup_realm = false
dns_lookup_kdc = false
[realms]
DOMAIN.COM = {
kdc = dcserver1.domain.com:88
admin_server = kerberos.example.com:749
default_domain = domain.com
}
[domain_realm]
.domain.com = DOMAIN.COM
domain.com = DOMAIN.COM
[kdc]
profile = /var/kerberos/krb5kdc/kdc.conf
[appdefaults]
pam = {
debug = false
ticket_lifetime = 36000
renew_lifetime = 36000
forwardable = true
krb4_convert = false
}


/etc/samba/smb.conf
# Global parameters
[global]
netbios name = SAMBASERVER
server string = Linux Samba server
realm = DOMAIN.COM
security = ADS
password server = *
encrypt passwords = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 0
local master = No
read only = No
case sensitive = Yes
dos filetime resolution = Yes
log level = 2
1 REPLY
Huc_1
Honored Contributor

Re: Samba 3.0 with Active Directory net ads join problem

I dont run ES3 or Samba 3

So I am afraid I am only able to search for some info that maybe of help ?

This is what a search on Failure code revealed, this is exactly like your problem but could help you along !

http://www.google.be/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=wcZ4.1Zu.13%40gated-at.bofh.it&rnum=1&prev=/groups%3Fq%3Dsamba%2B%2522%2BFailure%2BCode:%2B0x19%2522%26hl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26selm%3DwcZ4.1Zu.13%2540gated-at.bofh.it%26rnum%3D1

Hopefully this will help and others will be able to help you more .


J-P
Smile I will feel the difference