cancel
Showing results for 
Search instead for 
Did you mean: 

SecurePath + Linux + LVM ?

Efim Kushnir
Frequent Advisor

SecurePath + Linux + LVM ?

Dear Sirs.

We have :
1. HP ProLiant DL380G4 Servers.
2. OS - Linux RedHat ES 3.0 U3.
3. MSA1000.
4. Connection server to MSA1000 through FC HBA 2214 with driver ql2300.
5. All systems installed through SmartStart CD v.7.20
6. SecurePath v.3.0C for workgroup + SP1.

All equipment and drivers working properly.

We have some problem with create of logical volume through SecurePath device driver using Linux LVM.

We use the next commands for do it:
# pvcreate /dev/spdev/spa1
- this command working correctly, without errors
# vgcreate test_vg /dev/spdev/spa1
- the programm return error message about the such device not usable device.

/dev/spdev/spa1 is symbolic link to /dev/sda1

# vgcreate test_vg /dev/sda1
- it command work properly (why ?).

How we can install LVM on device of /dev/spdev/spa1 ?

BR,
Efim.
Look for the answers, do not stop !
3 REPLIES
Pedro Cirne
Esteemed Contributor

Re: SecurePath + Linux + LVM ?

Hi,


Please post the error you get when doing the vgcreate.

Pedro
Steven E. Protter
Exalted Contributor

Re: SecurePath + Linux + LVM ?

There is absolutely no reason why your setup should not be workable.

Since you do not provide the error message, I provide you with a general checklist:

mkdir a directory for the volume group.
mknod a device file in the directory you create.

Make sure the disk is not in another volume group with strings command on the /etc/lvmtab file.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Efim Kushnir
Frequent Advisor

Re: SecurePath + Linux + LVM ?

# pvcreate /dev/spdev/spa1
pvcreate -- physical volume "/dev/spdev/spa1" successfully created

# vgcreate test_vg /dev/spdev/spa1
vgcreate -- no valid physical volumes in command line

Here is problem message. For testing I also create /dev/spdev/spa1 special file except symbolic link. This physical volume contains 8e LVM partition type. Today I installed latest qla driver hp_qla2x00-2005-05-11.tar.gz. But it not helps. About creating directories for volumes - before invoking this command old test_vg volume created by /dev/sda1 was removed by vgremove. No more LVM information on this device can be.
Look for the answers, do not stop !