Showing results for 
Search instead for 
Did you mean: 

TERM variable

Teck Sim
Frequent Advisor

TERM variable

I was trying to de-install oracle database software on HP-UX 11. I did a cold-install from HP-UX 10.20
[SMT1:/u01/app/oracle/product/7.3.4/orainst]> ./orainst

Supported Terminals are:
3151 386 386s 386u 386x ansi avx3 dec dgd2 dgd4 hft hftc hp iris ncd sun sun5 tandm vt100 vt220 wy150 wy50 xsun xsun5
TERM=70096 ORACLE_TERM=70096
Can't find resource file
/u01/app/oracle/product/7.3.4/orainst/ ./tk2{TERM}.res or
/u01/app/oracle/product/7.3.4/orainst/ ./tk2{ORACLE_TERM}.res
Please set your TERM variable to one of the supported terminals.
Exiting orainst procedure.

How do I change or set up the TERM.
Please help.
James R. Ferguson
Acclaimed Contributor

Re: TERM variable

Hi Teck:

Generally this is done automaticall when you login via '/etc/profile'. However you can do, for example:

# export TERM=vt100


T G Manikandan
Honored Contributor

Re: TERM variable

Define the TERM variable in the .profile flle of the oracle user.

$TERM=vt100;export TERM

re-login again.

if it is c shell
$setenv TERM vt100

Brant Evans
Occasional Advisor

Re: TERM variable

If you are using the posix shell (sh) then you may have to issue the command in two steps.
TERM=vt100; export TERM

If you are using the c shell (csh) the following command will set the term varialbe
setenv TERM vt100
Teck Sim
Frequent Advisor

Re: TERM variable

I have set TERM=vt100. Thanks.

Now, I am in Installer, and the Installer asks for $ORACLE_HOME location:, which is default to :/u01/app/oracle/product/7.3.4, and I pressed enter, and I got this message:

A write error occurred while trying to modify ' ' in '/u04/apps/oracle/product/7.3.4/orainst/install.log'. (no such file or directory) Would you like to retry the operationm ignore the error, or allow the error to be processed by the Installer.

There aren't any 'ignore' button, so I did retry and process, and I got another message:

unix.stp(3563):WRITE_ERROR while modifying in '/u04/apps/oracle/product/7.3.4/orainst/install.log.

I did a bdf, or mount and I don't see any u04 at all.

Please help.
Bill Hassell
Honored Contributor

Re: TERM variable

Oops! DON'T set TERM=vt100. Since TERM=70096 already, that means you are using a smart HP terminal and things will be really screwed up by telling applications to use incompatible escape sequences such as the vt100.

When you login, the standard /etc/profile will run ttytype to 'guess' what terminal you have. Since HP terminals are quite smart, they identify not just a family bu the actual model number. Unfortunately, some manufacturers use an older termcap style of terminal handling and have a limited number of terminal features. Since Oracle shows hp as a 'supported' terminal, just echnge TERM to hp as in:

export TERM=hp

and continue. Some syadmins have bee told to change HP smart terminals into dumb vt100's on the new N/L/A class computers--which is neither necessary nor desirable. See this comment I made about HP terminals:,,0x60e09200caded5118ff40090279cd0f9,00.html

Since your terminal is responding to the ttytype query as a 70096 model (which is correct), then change TERM to hp to satisfy the limited Oracle selections.

Bill Hassell, sysadmin
Joseph C. Denman
Honored Contributor

Re: TERM variable

Hi Teck,

I agree with Bill. Try setting you TERM to hp. However, I do believe I have used vt100 in the past. It has been awhile since 7.3.4????????

export TERM=hp

Also, you really don't have to use the orainst to de-install the software, but you will have to resolve the issue to reinstall with the 11.0 version.

rm -rf /u01/app/oracle/product/7.3.4

If I had only read the instructions first??
Brian Crabtree
Honored Contributor

Re: TERM variable

Well, in Oracle7 and Oracle8, you dont need to deinstall anything. Just delete the old ORACLE_HOME and move on. In 8i, you should deinstall so that it doesn't clutter your OUI (Oracle Universal Installer).

The enviroment variables you are looking for probably are:


This should let you into the installer. Make sure you have an /etc/oratab in place, or you need to set the following:


Hope this helps,