Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

TNS 12224 error - Problem during the oracle upgrade

Go to solution

TNS 12224 error - Problem during the oracle upgrade

I am doing the oracle upgrade 816 to 817. All procceds normally until the Database Configuration trys to run this fails with the following error:
ORA 12224 TNS: lost conctat

I installed the unix patch PHSS_22478 and relink the oracle.
I recreated the tnsnames.ora, listener.ora and sqlnet.ora.

I have a SAP application and When I trying to do one test like this: R3trans -d I receive the error message:
Fatal NI connect error 12224
TNS - 12224
TNS - 12541
TNS - 00511

I am not finished the upgrade and the oracle HOme is /oracle//817_64 , I don??t know if in this point the listener need to have the new home or the old home.

Eliane Lui
George Petrides_1
Honored Contributor

Re: TNS 12224 error - Problem during the oracle upgrade

Although the binary of the listener might work from 8.1.6, the right thing to do is start the listener from the new version, therefore set the listener oracle home to 8.1.7. Also, make sure that the listener.ora file is the same on 8.1.7. If you try a tnsping to that instance is it OK? If you try doing
sqlplus system/PASSWORD@INSTANCE you should get the same error that SAP gives you. Do also a lsnrlctl status and paste the output here. I take it that your database works OK and you can start it, connect to it with svrmglr and sqlplus without the @INSTANCE option. When I saw this problem before, the solution was re-linking the Oracle binaries but you said you already did that. Make sure that all your ORA... variable are pointing to the new ORACLE_HOME (shared libraries path, binary path, etc.)

Re: TNS 12224 error - Problem during the oracle upgrade

Dear George,

Thanks for your help, but see my comments

Output for lsnrctl stat
capoeira:orai95 30> lsnrctl stat

LSNRCTL for HPUX: Version - Production on 21-JUL-2002 22:56:40

(c) Copyright 1998 Oracle Corporation. All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=IPC)(
Version TNSLSNR for HPUX: Version - Production
Start Date 20-JUL-2002 16:16:53
Uptime 1 days 6 hr. 39 min. 47 sec
Trace Level off
Security OFF
Listener Parameter File /etc/listener.ora
Listener Log File /oracle/I95/817_64/network/log/listener.log
Services Summary...
I95 has 1 service handler(s)
The command completed successfully

Part of Output for env:

Output for tnsping:
capoeira:orai95 33> tnsping I95

TNS Ping Utility for HPUX: Version - Production on 21-JUL-2002 22:58:22

(c) Copyright 1997 Oracle Corporation. All rights reserved.

Attempting to contact (ADDRESS=(PROTOCOL=TCP)(HOST=I95)(PORT=1521))
TNS-12541: TNS:no listener

George, the tnsping doesn??t working....
I relink the oracle with this command
make -f ioracle

Do you have another recommendations?

Thanks ,
Eliane Lui
Jeanine Kone
Trusted Contributor

Re: TNS 12224 error - Problem during the oracle upgrade

Have you double checked your tnsnames.ora to make sure that it is correct and resolving to the right address. Also make sure you are using the tnsnames.ora from the correct location.
Dave Chamberlin
Trusted Contributor

Re: TNS 12224 error - Problem during the oracle upgrade

Make sure that the port number matches in tnsnames.ora and listener.ora.
Julio Yamawaki
Esteemed Contributor

Re: TNS 12224 error - Problem during the oracle upgrade


Probably, you have the wrong ORACLE HOME in your listener.ora, please check to see if you have ORACLE HOME=/oracle//ora816 and change this entries to your new ORACLE HOME.

Re: TNS 12224 error - Problem during the oracle upgrade

Thanks ,

I resolved the problem whith the Dave??s suggestion.
I don??t know why but the listener tried to connect the port 1521 but all file were configured to use the port 1527.
I changed the files to use the port 1521.

Thanks a lot,
Eliane Lui
George Petrides_1
Honored Contributor

Re: TNS 12224 error - Problem during the oracle upgrade

From the info that you provided it was either port or hostname issue. Please read the ITRC etiquete regarding assigning points.