General
cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong character mapping in console mode

 
Honored Contributor

Re: Wrong character mapping in console mode

(Sorry about the late answer; I forgot to check this thread again after Easter holidays.)

According to the ASCII table, 2D is the correct hex value for the minus sign, and 5E for the caret. So the keyboard input side seems to work OK and the problem should be somewhere in the output path.

Can you please list more of the non-functional characters? Perhaps there is a pattern of some sort.

I would still like some more details about "console mode". Because the keyboard selection affects the problem, this does not seem to be simply a stty settings problem. But it might be useful to check that too: could you please run "stty -a > settings.txt" or something similar and attach the output to this thread?

Based on what you've said previously, I think you've disabled the graphic user interface (CDE) and are using the Internal Terminal Emulator. Am I right? Please confirm or correct me here; misunderstanding this detail would be severely misleading.

The ITE text mode would be mostly a product of firmware, so knowing the model of your system (and the display controller, if your workstation uses anything other than the default built-in one) would be important.

Do you see a row of 8 squares at the bottom of your screen? (If you don't, try pressing each of the function keys F1-F10 and see if anything happens.)

These would be the labels for the function keys: the ITE emulates a serial-attached HP terminal, and a real HP terminal can be configured (locally at the terminal side) using the function keys. The OS would have to have the correct stty settings to match the local settings of the terminal. With a real terminal, mismatched settings between the terminal and the OS could lead to various problems... but I just don't remember how much of these settings are available in the ITE.

The only other thing that might affect to the ITE is the console path setting. It is adjustable in the boot prompts. Unfortunately I cannot give you exact instructions for checking the console path without knowing the model of your workstation: there are some significant differences between models.

This might help some in finding out the console path setting:
http://www.pateam.org/parisc-linux-boot/PA-RISC-Linux-Boot-HOWTO/consoles.html

MK
MK

Re: Wrong character mapping in console mode

Hello Matti,

> Can you please list more of the non-functional characters? Perhaps there is a pattern of some sort.

Here are some more:

key pressed -------> screen output

# ---> ;
\ ---> Z
@ ---> =
| ---> N
paragraph sign ---> =
sharp s ---> ^
u umlaut ---> O
o umlaut ---> N
a umlaut ---> L


> could you please run "stty -a

Here is the output:

speed 9600 baud; line = 0;
rows = 0; columns = 0
min = 4; time = 255;
intr = ^C; quit = ^Z; erase = DEL; kill = ^U
eof = ^D; eol ; eol2 ; swtch = ^=
stop = ^S; start = ^Q; susp = ^Z; dsusp
werase = ^W; lnext = ^V
^parenb ^parodd cs8 ^cstopb hupcl cread clocal ^loblk ^crts
^ignbrk brkint ignpar ^parmrk ^inpck ^istrip ^inlcr ^igncr icrnl ^iuclc
^ixon ^ixany ^ixoff ^imaxbel ^rtsxoff ^ctsxon ^ienqak
isig icanon iexten ^xcase echo echoe echok ^echonl ^noflsh
echoctl ^echoprt ^echoke ^flusho ^pendin
opost ^olcuc onlcr ^ocrnl ^onocr ^onlret ^ofill ^ofdel ^tostop tab3


> Based on what you've said previously, I think you've disabled the graphic user interface (CDE) and are using the Internal Terminal Emulator. Am I right?

Yes


> knowing the model of your system...

The workstation is a 9000/785/C8000 running under HP-UX 11.11. It is connected to a monitor LP2475w


> Do you see a row of 8 squares at the bottom of your screen?

Yes. the 8 yellow squares are there. Only three of them are labeled:
F4: Remote Mode
F7: Display Functns
F8: Auto LF


New Member

Re: Wrong character mapping in console mode

I had same problem (but when I pressed '-' I saw 'ì'). I solved in this way:

in SingleUserMode:

NUM-LOCK

(now the label on the yellow squares on your screen will change)

F8 - config keys
F5 - terminal config
press TAB until you are on ASCII 8 Bits (you have to press it 5 times)
F2 - NEXT CHOICE (ASCII 8 Bits must be YES)
F1 - SAVE CONFIG

have fun ;)

make me know if it works...
Honored Contributor

Re: Wrong character mapping in console mode

This Num-Lock key worked fine for me when a "F1 T LABEL ..." screen appeared on the concole.
Each and every day is a good day to learn.