Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

create an oracle instance

create an oracle instance

I have installed Oracle 8.1.7 on a D350 running 11.0.

I can use sqlplus to connect to remote databases running on other machines fine but I can not create a local instance.

I used the dbassist program to create the sql files and when I run them I get the following messages:
$ ./test.sh

Oracle Server Manager Release 3.1.7.0.0 - Production

Copyright (c) 1997, 1999, Oracle Corporation. All Rights Reserved.

Oracle8i Enterprise Edition Release 8.1.7.0.0 - Production
JServer Release 8.1.7.0.0 - Production

SVRMGR> SVRMGR> Connected.
SVRMGR> ORA-03113: end-of-file on communication channel
SVRMGR> 2> 3> 4> 5> 6> 7> 8> 9> 10>
CREATE DATABASE "test"
*
ORA-03114: not connected to ORACLE
SVRMGR> Disconnected.
SVRMGR> SVRMGR> Server Manager complete.
$

The script running is below:
#!/bin/sh
ORACLE_SID=test
export ORACLE_SID

/oracle/app/oracle/product/8.1.7/bin/svrmgrl << EOF
spool /oracle/app/oracle/admin/test/create/crdb1.log
connect internal
startup nomount pfile = "/oracle/app/oracle/admin/test/pfile/inittest.ora"
CREATE DATABASE "test"
maxdatafiles 254
maxinstances 8
maxlogfiles 32
character set US7ASCII
national character set US7ASCII
DATAFILE '/oradata3/oradata/test/system01.dbf' SIZE 260M AUTOEXTEND ON NEXT 1024
0K
logfile '/oradata3/oradata/test/redo01.log' SIZE 500K,
'/oradata3/oradata/test/redo02.log' SIZE 500K,
'/oradata3/oradata/test/redo03.log' SIZE 500K;
disconnect
spool off
exit


It is dieing on the startup nomount pfile line.

What am I doing wrong?

I looked on Oracle's site for the ORA-03113 message and can only find references to receiving this message if an instance you are connected to is shutdown.

I am just trying to set up a small development instance but will probably run into this same problem trying to create a production database.

Any help will be appreciated!
5 REPLIES
Gadura Praveen
Frequent Advisor

Re: create an oracle instance

Hello Kevin,

Does your script has a "EOF" at the end ? If not, put a EOF after the exit statement in your script. Basically "svrmgrl" will try and execute everything until it encounters EOF.

Hope this helps !

Praveen

Re: create an oracle instance

I did not include the EOF in the cut and paste but it is there.

This is from the command line:
$ svrmgrl

Oracle Server Manager Release 3.1.7.0.0 - Production

Copyright (c) 1997, 1999, Oracle Corporation. All Rights Reserved.

Oracle8i Enterprise Edition Release 8.1.7.0.0 - Production
JServer Release 8.1.7.0.0 - Production

SVRMGR> connect internal
Connected.
SVRMGR> startup nomount pfile = "/oracle/app/oracle/admin/test/pfile/inittest.ora"
ORA-03113: end-of-file on communication channel

What is wrong the the startup nomount pfile line?

The inittest.ora file was created by dbassist.
John Poff
Honored Contributor

Re: create an oracle instance

Hello,

Here is a thread where someone reported a similar problem. They solved it by increasing the SEMMNS kernel parameter from 200 (which Oracle recommended) to 500.

http://forums.itrc.hp.com/cm/QuestionAnswer/1,1150,0x92f8a12d6d27d5118fef0090279cd0f9,00.html

Good luck!

JP
ajax13
Frequent Advisor

Re: create an oracle instance

Hi,
I am not sure if this would help, but you may wanna set your environment variables, such as
ORACLE_HOME,SHLIB_PATH,PATH. You may wanna try run oracle.profile or oraenv.

Thanks

Re: create an oracle instance

It was a kernal parameter but it was shmmax. Another system admin had lowered the parameter since I had bumped it up. Setting it to 1 gig did the trick. (It was set at 100 Meg).

Thanks for the idea!