cancel
Showing results for 
Search instead for 
Did you mean: 

hp doesnt support LINUX???

Erdem Kurul
Occasional Contributor

hp doesnt support LINUX???

I have the same problem installing linux to my ZE4125, kernel panic on PCMCIA. I tried both Mandrake or Redhat, and I do want my PCMCIA work. So I emailed HP about it, their response was short. We dont support linux. What does that supposed to mean? I didnt want help installing linux, I just asked them to fix their problem. Is it acceptable that linux works on any other laptop but not HP. I dont think they can even understand the problem.
Well, anyways... Does anyone tried Suse 8.1?
Thanks...
Erdem
---
Erdem
6 REPLIES
Bill Thorsteinson
Honored Contributor

Re: hp doesnt support LINUX???

Most manufacturers do not actively support Linux.

For laptop issues I check at:
http://www.linux-on-laptops.com/hp.html

I don't see an entry for ZE4125 under HP, but there is one for a ZE1110.
It may provide you with the hints you need.
dirk dierickx
Honored Contributor

Re: hp doesnt support LINUX???

Most vendors don't support linux on the desktop yet. so you are mostly on your own for laptops and workstations (although HP has some power workstations with linux on them).
http://www.linux-laptop.net - this site will mostly answer all of your questions regarding linux on laptops.
Duncan Gibb
Occasional Visitor

Re: hp doesnt support LINUX???

How much Linux support you get seems also to depend on which country you're in:

http://linux.compaq.co.jp/

has some (not terribly up-to-date) laptop-specific info, including how to install the Lucent modem drivers under RedHat.


I suppose the main bar to offering Linux support is the training cost for first-line support personnel. First-line support aren't usuaully able to offer much advice beyond "are you sure it's plugged in?" and "you need to re-install Windows". If you can get past them to the second-line support, you're much more likely to get to speak to someone with a brain who can tell you what the problem really is - and maybe even solve it.

I agree that it is a pitty HP don't seem to realise that there are quite a few of us who buy their hardware specifically and exclusively to run Linux on it. Perhaps they will realise that they are losing ground to IBM on this front and get their act together.
Ken Giusti
Occasional Visitor

Re: hp doesnt support LINUX???

Sad to say, but I doubt HP is going to help us out here.

I'd certainly like to register my dissatisfaction over this problem, but unless we can find the "right" person to complain to, we're not going to get anywhere. We need to find an advocate within HP. Too bad Bruce Parens no longer works there. If anyone finds an name/email/phone # of a person with influence, please post it here so we all can help send a clear message to HP.

Otherwise, from what I can tell, there is no work-around for this problem. The pcmcia-cs module just does not work with this laptop.

But I'm not giving up hope yet. The whole purpose of open source is to be able to modify the software to get it to do what you need it to do. Jacek Pliszka seems to be doing quite a bit of sw hacking on this very problem. Unfortunately, I know nothing about pcmcia internals, but I'm a sw engineer and I will try to do what I can. If HP refuses to help, maybe someone else can.

There's more discussion about this on the pcmcia-cs forum on sourceforge.

http://sourceforge.net/forum/forum.php?thread_id=757551&forum_id=7049

Bill McNAMARA_1
Honored Contributor

Re: hp doesnt support LINUX???

try http://www.hp.com/go/linux

Later,
Bill
It works for me (tm)
Sandra Gent
Occasional Visitor

Re: hp doesnt support LINUX???

I have successfully installed Linux on the ze4145 using the SuSE 8.1 distro. Please write me if you have more problems.

How to install SuSE Linux 8.1 on HP ze4145

Preamble

The hp ze4145 is a full featured notebook including an AMD Athlon processor.
It should make an ideal Linux box however in the news groups there has been
little success in successfully loading Linux on the box. After acquiring a
4145 I went through the same problems.

Introduction

If you follow an unmodified installation procedure, the system will "panic" when
probing IO. A panic is indicated by an unresponsive system and the caps lock led
flashing. If the system panics, you should be able to power cycle the machine by
holding the fn key and the power switch for a few seconds. If that fails then
press the reset button under the system

Other Systems

RedHat 8.0 panics very early in the installation process and no "standard"
settings will allow you to make progress. One enterprising installer pulled the
hard drive, installed RedHat and then recompiled the kernelto disable isapnp.

SuSE Install

Follow the normal installation process up to the first boot. If you allow the
system to continue it will panic, you need to set the following boot flags
before continuing:

pci=acpi
NOPCMIA=yes
hwprobe=-ispnp

I also set the frame buffer graphics to code 791 to use 16bit color and 1024 x
796 display size.

If the system panics at the hardware scan, proceed as follows:

Boot CD1, (press esc key and select CD)
Start the installation process over until you have the option of booting the
installed system.
Select Boot Installed System

The system will load to the graphical login. Login using your user name and
then open an xterm (shell window). Switch to SuperUser (su) and type
chkconfig. You will notice hwprobe is set to yes. Enter the command
chkconfig -s hwprobe no
to disable hardware probe.

Next cd to /etc/sysconfig and modify the last line of the pcmcia file to read

PCMCIA_CORE_OPTS="probe_io=0"

Next cd to /boot/grub and modify the linux command line to include pci=acpi,
at the same time you can set your frame buffer parameter if you want, mine is
set to 791.

title linux
kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 hdc=ide-scsi vga=791 pci=acpi


Now shut down the system and reboot.

This time the system should reboot correctly.

If you want sound, switch to SuperUser:

modprobe trident
modprobe soundcore
modprobe sound

Verify that the sound system is working by using xmms and playing a suitable
audio file.

Your network card should have been recognised correctly.

Warning:

If you use YAST2 to try and change the hardware configuration, YAST2 will start a
probe and panic, minimally it will generate a machine check and the system will
hang requiring a reboot.

Things To Do

1. Find out how to prevent YAST2 from machine checking
2. Install the correct graphics driver to not require frme buffer graphics
3. Rebuild the kernel to exclude the problem isa sub components.