cancel
Showing results for 
Search instead for 
Did you mean: 

perl module installation error

SOLVED
Go to solution
Joseph P. Marino
Occasional Advisor

perl module installation error

I just upgraded 5.00.5 to 5.6.1f
using swinstall
I ran perl -v and it gave me a old version
So I went on forum read about /usr/contrib/bin
rename the old perl to perl.old and put a new version
So far so good perl -v works
and I am a happy man

Our DBA asked me to install modules
DBI and DBD which should be easy

perl Makefile.PL
And I am getting this error:

# perl Makefile.PL
Can't locate Test/More.pm in @INC (@INC contains: lib /opt/perl/lib/5.6.1/PA-RISC1.1-thread-multi /opt/perl/lib/5.6.1 /opt/perl/lib/site_perl/5.6.1/PA-RISC1.1-thread-multi /opt/perl/lib/site_perl/5.6.1 /opt/perl/lib/site_perl .) at Makefile.PL line 39.
BEGIN failed--compilation aborted at Makefile.PL line 39.
#

P.S. help with install "Test/More.pm"
I went on CPAN and found the sourse code ....and got stuck
what next

2 REPLIES
H.Merijn Brand (procura
Honored Contributor
Solution

Re: perl module installation error

If you are using a more recent DBI (1.45) and/or DBD_Oracle (1.16), Test::More is now a prerequisite module

For those two, I'd also recommend using perl-5.8.x (5.8.3 or 5.8.5) because it has a lot of fixes related to Unicode, and you are bound to meet those any day soon in modern databases

Sorry, but 5.6.1 is now considered old. There is already a 5.6.2 maintainance release available in the 5.6.x track, but the 5.8 track is considered the stable release, with 5.8.6 coming out in a few weeks (if all goes well)

If you can't find a depot with perl-5.8 (http://hpux.connect.org.uk/hppd/hpux/Languages/perl-5.8.5/ only has depots for 11.11), you can still find almost any build for all HP-UX pa-risc versions on my site, and they include the most recent DBI at the moment of my bundle release (for my 5.8.5 builds that is DBI-1.43)

My HP ITRC site pages can be found at (please use LA as primary choice):

USA Los Angeles http://mirrors.develooper.com/hpux/
SGP Singapore https://www.beepz.com/personal/merijn/
USA Chicago http://ww.hpux.ws/merijn/
NL Hoofddorp http://www.cmve.net/~merijn/

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Joseph P. Marino
Occasional Advisor

Re: perl module installation error

OK I am back installed 5.8.5 went gooood
copmiled...everything OK
Installed DBI 1.45 ...looking good

Start installing DBD-Oracle1.15

and on make test it fails
I included output of perl -V
attachement error message for make test


# perl -V
Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
Platform:
osname=hpux, osvers=11.11, archname=PA-RISC2.0
uname='hp-ux mpc120 b.11.11 u 9000800 2660268794 unlimited-user license '
config_args='-de'
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='cc', ccflags =' -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings -D_LARGEFILE_SOURCE ',
optimize='-O2',
cppflags='-Aa -D__STDC_EXT__ -D_HPUX_SOURCE -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings'
ccversion='B.11.11.02', gccversion='', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=4
alignbytes=8, prototype=define
Linker and Libraries:
ld='/usr/bin/ld', ldflags =' -L/usr/local/lib'
libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib
libs=-lnsl -lnm -lndbm -lmalloc -ldld -lm
perllibs=-lnsl -lnm -lmalloc -ldld -lm
libc=/lib/libc.sl, so=sl, useshrplib=false, libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-B,deferred '
cccdlflags='+Z', lddlflags='-b +vnocompatwarnings -L/usr/local/lib'


Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under hpux
Compiled at Oct 26 2004 12:34:58
@INC:
/opt/perl5/lib/5.8.5/PA-RISC2.0
/opt/perl5/lib/5.8.5
/opt/perl5/lib/site_perl/5.8.5/PA-RISC2.0
/opt/perl5/lib/site_perl/5.8.5
/opt/perl5/lib/site_perl