Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

restore of dump file problems

Occasional Visitor

restore of dump file problems

I am trying to restore a file created with dump. The directory structure gets created but I get the following error for each data file: "cannot create file: No space left on device".

The dump file is 4GB and the filesystem I am trying to restore into is 18GB. Plenty of room.

I have even tried to restore individual files using interactive mode but get the same error.

The restore command I use is:
`restore axf `

Unfortunetly the admin who created this archive is no longer around and I do not know what options were used with the dump command.

Appreciate any help - thanks.
Stuart Browne
Honored Contributor

Re: restore of dump file problems

What platform/OS was the dump file created on?

What media is the dump file on? On the HDD?

What OS/Distribution are you trying to restore to?
One long-haired git at your service...
Johannes Krackowizer_1
Valued Contributor

Re: restore of dump file problems

Ok at this moment my only idea is:

does the filesystem support files of 4GB size.

for more information please post some informations like:
filesystem (mountpoints, size, filesystem-type like ext2, ext3, reiserfs, ...)

best regards

"First off, I'd suggest printing out a copy of the GNU coding standards, and NOT read it. Burn them, it's a great symbolic gesture." (Linus Torvalds)
Occasional Visitor

Re: restore of dump file problems

OS = RH Linux 2.4.18-14
FS = ext3

The dump archive was created to a file on the same server I am trying to restore to.

Once the restore has completed with the space full errors I have tried to create a dir or touch a file but I get a device full error yet df is showing 17GB+ free.

I then remove the dir structure that was just created I can fill the filesystem up to its 18GB with junk files so the filesystem and df's reporting appear to be OK.
Occasional Visitor

Re: restore of dump file problems

I have successfully restored a 2GB archive into the same filesystem but failed to restore another 4GB from a different date.

Seems to be some limit on the filesystem.

Is it possible I'm running out of inodes and not disk space?

Is the inode limit per filesystem or generic setting for all filesystems?

Occasional Visitor

Re: restore of dump file problems

I haven't solved the problem but I have a workaround i.e. interactive mode allows me to install a few dirs at a time.