General
cancel
Showing results for 
Search instead for 
Did you mean: 

rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

 
Dalan Campbell
Occasional Advisor

rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

I have an rp3440 (HP-UX 11i v1) with two SA6402 controllers, one for internal disks and one to external MSA30DB. I have two drives in internal bays 0 and 2 which are mirrored (RAID 1+0) which have been working fine. I want to add a drive in bay 1 as a single RAID 0 logical volume (this bay should be on the same controller port as bay 0). When I insert the drive it does not show up in the saconfig list of physical drives. When I insert a drive in the MSA30DB it shows up immediatly in the list with a status of unassigned. When I removed the drive from bay 1 it was detected and sent a "SCSI device was removed" event notification. Any idea why I don't see the drive on the saconfig physical drives list?
7 REPLIES 7
Torsten.
Acclaimed Contributor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

Please post a

# ioscan -fn

with new disk inserted.

The 2 lower internal drives are on the same bus, the top drive is on a different bus.

By default both busses are connected to the internal controllers, but you can either connect 1 bus or both busses to the smartarray.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dalan Campbell
Occasional Advisor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

Torsten - here is the ioscan. yes bay 0 is the bottom drive and bay 2 is the top. The documentation says bay 0 and 1 are on the same backplane connector so whould both be on the same controller channel.
Dalan Campbell
Occasional Advisor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

Also here is the saconfig listing for the external and internal controllers. The internal does not show the drive which is in bay 1. Could the drive itself be the problem? I have not used this drive before. Can I just change drive carriers and try this drive in the MSA30 slot?
Torsten.
Acclaimed Contributor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

It could be a problem with the disk or the disk backplane.

For testing, I would try to push the drive into the MSA.
Another option is to shutdown the server and swap the disk from the bottom slot to the middle slot to see if the known good disk work in this slot too.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dalan Campbell
Occasional Advisor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

I have change the internal drive carrier to the external carrier (the one that fits the MSA30DB) and tried the drive in the MSA30 unit. It is recognized fine by the 6402 controller (saconfig attached). So the drive works.

Since the internal RAID 1+0 is running with the drives in bay 0 and bay 2 it has to be cabled correctly (A7231-63025 dual channel RAID cable). There are two backplane connectors, 'A' and 'B' (A is for bay 0 and bay 1; B is for bay 2). I have actually tried the drive in two different rp3440s and it does not show up on either.

Any other suggestions?
Dalan Campbell
Occasional Advisor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

The fix was to update the firmware in the SA6402. I had v2.58, upgrade to v2.68 did not work, upgrade to v2.84 worked. I found this information to do the update:
http://bizsupport1.austin.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=120&prodSeriesId=367226&prodTypeId=329290&objectID=c01759073
Dalan Campbell
Occasional Advisor

Re: rp3440 with SA6402 Internal RAID doesn't see new bay 1 drive

firmware update v2.84 solved my problem