General
cancel
Showing results for 
Search instead for 
Did you mean: 

script go failed service on red hat cluster suite 4.5

maurizio di salvo
Frequent Advisor

script go failed service on red hat cluster suite 4.5

Please i have this problem who can help me???

i have setting cluster from two server, the cluster with this config is ok:

j have create 6 resource (4 file system resource and two ip address), then i have create two service, in each service there is one ip address and two file system. when i shutdown one server the service go at other server. when i drag and drop a service from node1 at node2 and viceversa is all ok.

the problem born when i add a script in a resource and add resource script at one service. the service on node1 start ok, but if drag and drop the service at node 1 at node 2 i read---->stopping, recovering and failed the same if i shutdown node 1. if i delete script on the service all return in ok status.

where is the problem??

thanks for all
4 REPLIES
Ivan Ferreira
Honored Contributor

Re: script go failed service on red hat cluster suite 4.5

Check /var/log/messages and your script must return exit code 0 to be sucessfull.

Ensure that your script is working properly specially the stop part.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: script go failed service on red hat cluster suite 4.5

Shalom,

To really help properly, I'd need to see /var/log/message snip and cluster.conf and the startup script.

note that starting up services with the standard /etc/init.d script won't failover properly.

Before starting a service clumanager always tries to stop it whether its running or not. This gets a non-zero return code and screws up failover. A good example of this is httpd.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
maurizio di salvo
Frequent Advisor

Re: script go failed service on red hat cluster suite 4.5

thanks boys i have found a solution because i have modify file hosts an msa 1000 is gone in confusion . when i have excute off and on of masa1000 all is ok. thanks for all.
maurizio di salvo
Frequent Advisor

Re: script go failed service on red hat cluster suite 4.5

thanks boys i have found a solution because i have modify file hosts an msa 1000 is gone in confusion . when i have excute off and on of masa1000 all is ok. thanks for all.