Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

/usr/ccs/bin/ld: Can't find library for -ljava

SOLVED
Go to solution
Mark Blonde
Advisor

/usr/ccs/bin/ld: Can't find library for -ljava

I have a clean HP-UX install with 11i. Trying to re-link oracle 8.1.7 with the command:

make -f ins_rdbms.mk install

but I get an error:

/usr/ccs/bin/ld: Can't find library for -ljava
*** Error exit code 1

Stop.


I have hp-ux 64.bit 11i.
I found on ITRC that the default HP-UX 64-bit installation does not create a few required X-library symbolic links. (It mentions hp-ux 11.0, but I'm not sure if it applies to 11.11). These links must be created manually before starting the Oracle installation. I'm not sure if this problem has been fixed, but I assume so.

On a different system, I had a different (similar) problem. Here WAS the error message
Make: Don't know how to make /finpro6/nav07/oracle/8.1.7/rdbms/lib/libknlopt.a. Stop.
*** Error exit code 1

I finally had to do the following link
ln -s libmm.a libobk.a
in the following directory /finpro6/nav07/oracle/8.1.7/rdbms/lib. That helped me get a little further, I was then getting the unsymbolic error message. I read on ITRC that if you mix ANSI/C and HP aC++ together, it could cause problems, so I removed the aC++ product and rebooted the hp box. And the link worked. That was on a different system. But as you can see, it was a different error message. So far, with the current system that is having the problem, I have removed the HPaC++ product and rebooted. I only have ANSI/C as the compiler. Have any ideas ?

Let me know if I need to give you more information.
If you don't have what you want, want what you have.
2 REPLIES
Mark Blonde
Advisor

Re: /usr/ccs/bin/ld: Can't find library for -ljava

Our dba tried to make again and now, we are getting a different error message. It seems to indicate that it's a link problem. Any help is very much appreciated!

/reppro/rep01/oracle/8.1.7/rdbms/lib> make -f ins_rdbms.mk
Make: Don't know how to make /reppro/rep01/oracle/8.1.7/rdbms/lib/skgxpd.o. Stop.
If you don't have what you want, want what you have.
Steven E. Protter
Exalted Contributor
Solution

Re: /usr/ccs/bin/ld: Can't find library for -ljava

I'd go back and make sure you don't need that c++ compiler you ripped out. I think you may have made things worse there.

Step 1. From the applications cd, install latest version of ansi/c and c++ compilers.

Step 2. December 2002 Patch set. Can't hurt.

Step 3. http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=43507.1

check the 11.11 patch list, go get them at itrc.hp.com, checking for supersedes.

Step 4. http://www.hp.com/products1/unix/java/infolibrary/patches.html

Check for and install java patches required by your java version. Might also first want to make sure you have most current version of 1.2 or 1.3 java. 1.4 java is not certified with Oracle.



Then relink oracle.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com