Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

LUns not getting visible on two VM simultaneously

lovenanda
Frequent Visitor

LUns not getting visible on two VM simultaneously

Hi,

 

I have created two Vm from the host.when i was assigned the lun direct from the storage end on one vm guest working fine.but when i assigned the same way to another vm Lun its shows below errors.

 

EFI version 1.10 [14.62] Build flags: EFI64 Running on Intel(R) Itanium Processor EFI_DEBUG
EFI IA-64 SDV/FDK (BIOS CallBacks) [Tue Nov  1 13:13:08 2011] - HP
Cache Enabled. This image MainEntry is at address 0000000000102000
HP AVIO Stor Driver v1.0
HP AVIO LAN UNDI Driver v1.0
FPSWA.EFI preload successful.
FPSWA.EFI start successful.
VsdIssueIocbRequest: ComplQProducerIndex=0x0, ComplQConsumerIndex=0x0.
    vsd_iocb_hdr_t vch_iocb_hdr = {
      uint16_t  iocb_index      = 0x0
      uint16_t  next_iocb_index = 0xFFFF
      uint16_t  num_iocbs       = 0x1
      uint16_t  reserved        = (omitted)
      uint64_t  guest_context   = 0x0
      uint32_t  iocb_type       = 0x6
      uint32_t  iocb_status     = 0x0
    }
  }
VsdIssueIocbRequest: The IOCB has not been processed within 60 seconds.
VsdDiscoverDevice: VsdInquiryDevice() failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x0, Status=0x8000000000000007.
 CDB: { 0x12, 0x0, 0x0, 0x0, 0x80, 0x0 }
 IOCB status: 0x6, SCSI status: 0x0.
VsdDiscoverDevice: VsdInquiryDevice() failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x0, Status=0x8000000000000007.
 CDB: { 0x12, 0x0, 0x0, 0x0, 0x80, 0x0 }
 IOCB status: 0x6, SCSI status: 0x0.
VsdDiscoverDevice: VsdInquiryDevice() failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x0, Status=0x8000000000000007.
 CDB: { 0x12, 0x0, 0x0, 0x0, 0x80, 0x0 }
 IOCB status: 0x6, SCSI status: 0x0.
VsdDiscoverDevice: VsdInquiryDevice() failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x0, Status=0x8000000000000007.
 CDB: { 0x12, 0x0, 0x0, 0x0, 0x80, 0x0 }
 IOCB status: 0x6, SCSI status: 0x0.
VsdDiscoverDevice: VsdInquiryDevice() failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x0, Status=0x8000000000000007.
 CDB: { 0x12, 0x0, 0x0, 0x0, 0x80, 0x0 }
 IOCB status: 0x6, SCSI status: 0x0.
VsdDiscoverDevice: VsdInquiryDevice() failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x0, Status=0x8000000000000007.
 CDB: { 0x12, 0x0, 0x0, 0x0, 0x80, 0x0 }
 IOCB status: 0x6, SCSI status: 0x0.
READ command failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x4001000000000000, Status=0x8000000000000007,IOCB status=0x6, SCSI status=0x0.
READ command failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x4001000000000000, Status=0x8000000000000007,IOCB status=0x6, SCSI status=0x0.
READ command failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x4001000000000000, Status=0x8000000000000007,IOCB status=0x6, SCSI status=0x0.
READ command failed. PCI bus/dev=0x0/0x2, VSD LUN ID=0x4001000000000000, Status=0x8000000000000007,IOCB status=0x6, SCSI status=0x0.
EFI Boot Manager ver 1.10 [14.62] [Build: Tue Nov  1 13:13:08 2011]

Loading device drivers
EFI Boot Manager ver 1.10 [14.62] [Build: Tue Nov  1 13:13:08 2011]

Please select a boot option

    EFI Shell [Built-in]
    Boot option maintenance menu


    Use ^ and v to change option(s). Use Enter to select an option
Loading.: EFI Shell [Built-in]
EFI Shell version 1.10 [14.62]
Device mapping table
  blk0 : Acpi(PNP0A03,0)/Pci(2|0)/Fibre(WWN50001FE1501049C8,Lun4001000000000000)
  blk1 : Acpi(PNP0A03,0)/Pci(2|0)/Fibre(WWN50001FE1501049C9,Lun4001000000000000)
  blk2 : Acpi(PNP0A03,0)/Pci(2|0)/Fibre(WWN50001FE1501049CA,Lun4001000000000000)
  blk3 : Acpi(PNP0A03,0)/Pci(2|0)/Fibre(WWN50001FE1501049CB,Lun4001000000000000)

 

 

regards,

 

Shahzad

1 REPLY
Ing-Syst
Advisor

Re: LUns not getting visible on two VM simultaneously

What storage do you have with LUNs? What storage connection type do you use? What hosts do you present LUNs?