HPE EVA Storage

RSM Scripts and several problems

 
Zigoze
Honored Contributor

RSM Scripts and several problems

I have the following environment:

- 2 blade with Red Hat Linux 5.3 installed;
- 1 EVA 8400;

Presented to one of the blades I have:

- 1 System Lun with 200 Gb
- 1 Temp Lun with 500 Gb
- 1 Data Lun with 2 Tb + 1 Data Lun with 2 Tb + 1 Data Lun with 1 Tb group as a single volume group

Everything is configured with multipath.

I need a RSM (Replication Solution Manager) script that creates a snapshot of the System and Data volumes, and automatically mounts the snapshots on the second blade for backup purposes.

Can anyone help me?

Also, although i'm just giving my first steps at RSM, I've already tried some things. But I came across some problems:

- If I try to snapshot the host volumes (SnapshotHostVolume or SnapshotHostVolumeGroup) RSM is not able to identify the wwid of the lun (I get an error something like "null wwid"). I believe this has to do with the multipath configuration because I've tried on another host that has not multipath and it worked...

- Or, if I do the snapshot at the storage volume level, I will have the problem on mounting due to the 3 Data Luns grouped has a single volume group... how could I mount them recreating the volume group automatically on the destination host?

Can anyone help me?

Thank you
2 REPLIES 2
Del_3
Trusted Contributor

Re: RSM Scripts and several problems

RHEL 4 had the following noted problem. From the HP_RSM_Admin verision 4 guide page 51:

Missing HBA information
The replication manager HA fails to get HBA information from the SNIA Library on RHEL 4 U4 64-bit server. If the hbainfo.cfg file is missing or misplaced, the HBA Information id field is blank. You must install the hp_qla2x00-2007-01-11.tar.gz or later driver kit.

There is a work around to get the agent to see the HBA without the SNIA libraries. Its in one of the docs but I cant put my fingers on it at the moment.

My suggestion is you get the agent working and use one of the templates to accomplish your goal. It will save you much work scripting both in RSM and in Linux.
Zigoze
Honored Contributor

Re: RSM Scripts and several problems

O problem estava na versão de RHEL 5.3, a qual ainda não é suportada pelo RSM 5.0.

http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual〈=en&cc=us&docIndexId=64179&taskId=101&prodTypeId=18964&prodSeriesId=471572

ou
http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c01733112/c01733112.pdf